Jump to content

Help Backtrack 5 No Wifi


holytoledo
 Share

Recommended Posts

Do an ifconfig at the terminal, it should list all the adapters available to you.

Link to comment
Share on other sites

Do an lspci to show the hardware installed. If by chance you are running this in a VM, you won't see the card, since virtual machines only see USB wireless Ethernet adapters, and wired ethernet adapters. If its a native install or running off a live disc, then you can try the following.

Do a dmesg in a console, then make sure you enable the radio for the card if you have a hotkey on the keyboard(and hopefully a light indicator its on), then do a dmesg again, see if you get any hardware messages.

Also, you can do lsmod to see drivers for the cards installed, and try a modprobe for other rtl cards to see if its generic enough to find your card, although should be dtected with an "ifconfig -a", but I think the RTL8192SE is probably not supported by default yet and too new, and might need you to install drivers for it.

Get on via a wired connection and then download the drivers for it : http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2302

(Be sure to pick Linux drivers and for rtl8192se - Link should put you at them)

No guarantee it will do any kind of monitor mode or injection, but give it a shot. Might only allow you to surf with these drivers.

Link to comment
Share on other sites

I am using Backtrack 5 as my os and I am new to linex I tryed init.d/networking start and nothing came up? I am using a 1201n with a rtl8192se wireless card.

This is why you shouldn't use Backtrack as a main OS.

use wicd

Applications > Internet> Wicd

Link to comment
Share on other sites

This is why you shouldn't use Backtrack as a main OS.

use wicd

Applications > Internet> Wicd

I am finding that out. I want to get in to computer security possibly, so I though BT5 would be good to learn in. Any suggestions to which distro I should use? I got a few friends to use Ubuntu. Its nice and all but I like to use the underdog sometimes. I was using Mint which was nice as well I was waiting for the new one to come out.

Link to comment
Share on other sites

This is why you shouldn't use Backtrack as a main OS.

use wicd

Applications > Internet> Wicd

BT5 is pretty polished. I had BT4R2 on my laptop before BT5 and had no issues. There are a few things to work out with KDE X64 and getting X going, but those are negligible issues. Its probably the most stable version of backtrack I have ever used to date.

By the way, wicd has been installed in bt for a while now, but if he doesn't have drivers for his chipset, its not going to help him get online. Also, him being new to linux its good to know some other things to look at and try, since they aren't exclusive to bt, but all Linux.

Link to comment
Share on other sites

I have an Asus 1201n too, and I'm pretty sure that the default wireless card wont work;

Without certain drivers anyway. (Not too certain because I use my wifi adapter with BT.)

But yeah when I get home from school today ill see if it works with the default card/and if it

doesn't ill (see if its a driver problem) find the drivers you need.

Side note: Im pretty sure you can start wicd by typing "wicd start" into the terminal.

PS: Welcome to Linux

Link to comment
Share on other sites

I have an Asus 1201n too, and I'm pretty sure that the default wireless card wont work;

Without certain drivers anyway. (Not too certain because I use my wifi adapter with BT.)

But yeah when I get home from school today ill see if it works with the default card/and if it

doesn't ill (see if its a driver problem) find the drivers you need.

Side note: Im pretty sure you can start wicd by typing "wicd start" into the terminal.

PS: Welcome to Linux

wicd service should already be running on boot, just go to the start menu and then internet > wicd client.

Link to comment
Share on other sites

It might not be running at boot. Not sure if they kept backtrack to leave all interfaces off on boot to be "silent" like they used to.

After a native install, interfaces are set to auto and dhcp and wicd is running, at least on my machine. When I launch wicd from the menu, it starts scanning wifi and if on wired, does dhcp automatically. I believe you can go into /etc/network/interfaces to edit the options for dhcp and remove it. I think dhclient3 service is also running on boot after a full install.

On the live disc, I think you have the option to be silent on boot, with no networking(or swap) started via the grub menu options.

Link to comment
Share on other sites

I have an Asus 1201n too, and I'm pretty sure that the default wireless card wont work;

Without certain drivers anyway. (Not too certain because I use my wifi adapter with BT.)

But yeah when I get home from school today ill see if it works with the default card/and if it

doesn't ill (see if its a driver problem) find the drivers you need.

Side note: Im pretty sure you can start wicd by typing "wicd start" into the terminal.

PS: Welcome to Linux

I found wicd put it does nothing. I found the drivers how do I install them if that's the problem?

Link to comment
Share on other sites

I have an Asus 1201n too, and I'm pretty sure that the default wireless card wont work;

Without certain drivers anyway. (Not too certain because I use my wifi adapter with BT.)

But yeah when I get home from school today ill see if it works with the default card/and if it

doesn't ill (see if its a driver problem) find the drivers you need.

Side note: Im pretty sure you can start wicd by typing "wicd start" into the terminal.

PS: Welcome to Linux

Thanks! I had mint on it the other day I was perfect run great, but I wanted to try something more computer security stuff and thought that BT5 wound be fun to learn. Might Waiting for then new mint to come out in 2 weeks or try an other Linux dont know yet. Thanks again.

Link to comment
Share on other sites

I found wicd put it does nothing. I found the drivers how do I install them if that's the problem?

Uploaded driver to my site:

http://www.ticktockcomputers.com/rtl8192se_linux_2.6.0019.1207.2010.tar.gz

Download the file to your root folder.

Then open a terminal and do:

tar -xvfz rtl8192se_linux_2.6.0019.1207.2010.tar.gz

That should unzip the file. Then cd to the rtl8192se_linux_2.6.0019.1207.2010 folder and do a make and then make install, and reboot. This should install the driver for your card, and should then show up under ifconfig -a as wlan0 or similar. I don't have this card, so I cant test for you, but give it a shot. The readme file is detailed on how to do a lot of things and a nice reference for this driver, so read it a few times to get familiar with the commands, they are pretty much the same with all cards give or take a few iwpriv features not supported bu some cards.

Some trouble shooting for you too: http://ubuntuforums.org/showthread.php?t=1659802

Edited by digip
Link to comment
Share on other sites

After a native install, interfaces are set to auto and dhcp and wicd is running, at least on my machine. When I launch wicd from the menu, it starts scanning wifi and if on wired, does dhcp automatically. I believe you can go into /etc/network/interfaces to edit the options for dhcp and remove it. I think dhclient3 service is also running on boot after a full install.

On the live disc, I think you have the option to be silent on boot, with no networking(or swap) started via the grub menu options.

On my BT4 installs i have to dhclient eth0

i think the same with bt5, but not sure. haven't had much time to play. hell on the earlier releases you had to ifconfig eth0 up

Link to comment
Share on other sites

  • 2 years later...
Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...