Jump to content

RDP from vista


K-radical
 Share

Recommended Posts

Hey guys, I'm kinda new here as you can tell from my post count but I know a thing or two so I'll try not to make myself seem to retarded :D

So I've been messing around with Adito VPN on my Windows 7 Box and getting things configured quite nicely I might add. I am however running into a road block when attempting to connect to the RDP application I set up. I enabled everything properly on 7's end I'm not that much of a newb. The problem I'm getting is only occuring when atempting to connect from a Vista Box. I get this nasty little error says " wrong modulus size expected 64 +8 got 264"

Googling this tells me nothing except that a few others have had this same problem on Vista but none has been able to provide a solution. Any Ideas (besides of course use a different OS )

Thanks in advanced,

Link to comment
Share on other sites

You said " I get this nasty little error says " wrong modulus size expected 64 +8 got 264" "

Thats the first time i have seen that error but my first guess would be maybe one system was 32 bit and one was 64 bit and that caused some kind of error because of settings?

Link to comment
Share on other sites

are you useing a quad core? all 32 bit systems? I know on my windows 7 i had to configure it to allow certain users, yeah I am a noob but sometimes there are minor / easy things people overlook or forget about it.. does it work with regular windows RDP or it dont work with both regular windows RDP and the Adito VPN?

Link to comment
Share on other sites

Maybe use a third party remote desktop program like LogMeIn or VNC?

I'm kind of hoping for more of a solution than a work-around. Of course as a last minute effort I've concidred using VNC if I can't get this to work. But my budy has the exact same setup using RDP but he's running it on an XP server and connecting from XP clients. It's much faster than Ultra or Tight VNC.

On my end the server (windows 7) is set up properly. The issue occurs when trying to connect from a windows Vista client.

@555

Yes I'm using a Phenom II x4 940 quad. and all systems are 32bit

Link to comment
Share on other sites

I may be missing the point here, but can you not just run mstsc from the start menu and connect like that?

I guess I havn't tried that yet. Adito being SSL based I figured it would only work through shared apps I could launch from the browser isn't that right?

Your saying just connect to VPN and then atemp to launch remote desktop from windows not through adito?

I'll try that when I get home from school

Link to comment
Share on other sites

@555

Yes I'm using a Phenom II x4 940 quad. and all systems are 32bit

So your useing 32bit OS on a quad core pc? I know I have a dual core and use a 64 bit.. I have heard of even 86bit which i think is for quad cores to perform at their full performance power, and yeah i ussually just use the mstsc command, I know the version of windows could also depend like Home editions require you to ask for the remote assistance first, unlike Business and Ultimate editions where you can just take control over the computer at anytime

Link to comment
Share on other sites

So your useing 32bit OS on a quad core pc? I know I have a dual core and use a 64 bit.. I have heard of even 86bit which i think is for quad cores to perform at their full performance power, and yeah i ussually just use the mstsc command, I know the version of windows could also depend like Home editions require you to ask for the remote assistance first, unlike Business and Ultimate editions where you can just take control over the computer at anytime

A 16bit OS could make use of any number of processors if required and capable.

I doubt this problem is related to the architecture of the operating system. It would appear on the surface that it is a protocol mismatch of some nature that both the client or server was unable to resolve, notice how 264 is 8 more than 256 and the error states that it wanted 64 + 8 modulo.

Link to comment
Share on other sites

I guess I havn't tried that yet. Adito being SSL based I figured it would only work through shared apps I could launch from the browser isn't that right?

Your saying just connect to VPN and then atemp to launch remote desktop from windows not through adito?

I'll try that when I get home from school

I would personally stick to that myself, or use Server 2008 R2 RemoteApp. I'd also install a VPN server on a router, look at dd-wrt (for Linksys et al) or pfsense on x86 hardware, separation of roles sits better with me.

I know this doesn't fix your problem, but it might just interest you to look at different options.

Link to comment
Share on other sites

Lol some of you are going way to deep into this asking questiong about my CPU architecture. Still thanks for all the responses. The issue is JAVA related on the client side. I'm going to try a few things and I'm pretty confident one of them will fix the issue. I'll let you know when I get it worked out

Link to comment
Share on other sites

One thing I'll try later is making an SSL tunnel from the remote PC to my home box on port 3389, so it might work over Adito.

If you get this working I'd love to know how with either VNC or RDP or both. I attempted using RDP and it launched the aditio agent and said it was listening on the proper port, but when I tried to connect using localhost:3389 it gave me an error instantly which I forget what it said. I'll try again tomorrow and post if you haven't already gotten this to work.

Actually I just tried again and the adito agent launches fine this time I did get that same error as K-radical about the wrong module size. Then when I fire up the rdp client normally and attempt to connect to localhost or localhost:3389 I the error says:

The client cannot connect. You are already connected to the console of this computer. A new session cannot be established.

Link to comment
Share on other sites

  • 2 years later...

Hey guys, I'm kinda new here as you can tell from my post count but I know a thing or two so I'll try not to make myself seem to retarded <img src="http://forums.hak5.org/public/style_emoticons/<#EMO_DIR#>/biggrin.gif" style="vertical-align:middle" emoid=":D" border="0" alt="biggrin.gif" />

So I've been messing around with Adito VPN on my Windows 7 Box and getting things configured quite nicely I might add. I am however running into a road block when attempting to connect to the RDP application I set up. I enabled everything properly on 7's end I'm not that much of a newb. The problem I'm getting is only occuring when atempting to connect from a Vista Box. I get this nasty little error says " wrong modulus size expected 64 +8 got 264"

Googling this tells me nothing except that a few others have had this same problem on Vista but none has been able to provide a solution. Any Ideas (besides of course use a different OS )

Thanks in advanced,

Try to use this Java RDP client. Successfully added it to my Adito installation and it works with Win7 and Server 2008. Also take a look at this one.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...