Jump to content

Cannot reset my fonera 2100A/B/C


Recommended Posts

Hi,

I followed Darren's instructions 6 months ago, unlocked my fon 2100A/B/C and installed Jaseger. Today I wanted to play further but I do not remeber my SSH password. My fonera has an IP address 192.168.1.1 assigned to it. There is a reset button at the bottom, which I tried pressing when the device is on, waited 30sec, unplugged it and waited 30sec, plugged in - waited 30sec and it still remembers its IP settings. I googled several forums but just cannot find a way to reset my fonera.

Do you have any suggestions?

Thank you

Link to comment
Share on other sites

There is no easy way to recover the password without a cable. The reset button doesn't do anything.

If you want to try brute forcing it you could use something like brutessh or hydra, setup a dictionary with all your possible passwords in it.

Probably best to just re-flash with the new Jasager or Piranha firmware and start again.

Link to comment
Share on other sites

I am happy to re-flash again and start from scratch. Could you please guide me how to re-flash it? Without accessing to the router, is it possible to re-flash it?

Thank you

if you are using windows just connect with a cable and fire up friefunk (sp?)

ive had to do that probably a half dozen times

Link to comment
Share on other sites

Thank you digininja and Hurricane for the suggestions,

I plugged the fonera to my laptop with the cable and unplugged fonera from the power.

My Network card is to set to automatically recieve an IP address from DHCP.

I launched "Freifunk ap51", selected correct external files for rootfs and Kernel, selected the correct interface for the NIC.

Pressed on "Go" and pluuged the power cable to fonera.

It started reading the external files,

No packet

No packet

No packet

Peer MAC:

Peer IP: 192.168.1.254

Your MAC:

Your IP: 192.168.1.0

But actually at this time, my NIC was still trying to assign an IP address. It could not assign any IP so it ended up saying "limited connectivity" on the toolbar. I right-clicked for repair and it now assigned an IP from 192.168.1.181.

I can ping 192.168.1.1

Should I wait or do someting? I cannot telnet to 192.168.1.1 from port 23 or 9000

I see sometimes the internet LED on the fonera blinks but than it stops.

Did anyone experience this issue?

Thank you

Link to comment
Share on other sites

Your machine needs to have an IP before you start the process and that IP needs to be on the 192.168.1.0/24 subnet. If you aren't sure whether your Fon comes up in redboot as 192.168.1.1 or .254 then go for something else, .22 for example.

Set your IP, then bring up two shells and in one ping 192.168.1.1 and in the other .254. Power on the Fon and see which responds (use -t to keep the ping going). You will probably get 4 responses almost as soon as the fon gets power. Redboot usually only waits for between 2 and 10 seconds, any reply you get after that will be from the OS on the fon.

The one that responds is the IP of the Fon. I've never used any of the automated flashers so I don't know what info they need but this might help.

Link to comment
Share on other sites

I set my laptop's NIC card to 192.168.1.22 and like you adviced started to ping both .1 and .254.

After several "request time out"s, it started to ping 192.168.1.1 but actually this is the "Jaseger - Karma on the phone". The time, the ping attempt was successful, if I browse to http:\\192.168.1.1, I get to Jaseger page but my fonera has one sucessfully installed, the only issue that I do not know my password. So the time, my fonera is up, should I still wait longer with my Freifunk open? Because I have the feeling that it just does not start re-flashing, my fonera just turns ON and Jaseger starts as usual.

Any idea how I may re-flash or did I miss any step?

Thank you

Link to comment
Share on other sites

We seem to be at cross purposes, let me say where I think we are at...

You've forgotten your password so the options are either to build a cable and use that to reset the password - it allows you in without a password - or to reflash. To reflash just use one of the many different ways to do the flash, there are at least 2 windows apps which I never remember the names of or the linux perl script redboot.pl which is what I use.

From what you were saying I think you had problem with the windows app connecting and doing the flash, this would be because either the windows box was on the wrong IP/subnet so couldn't access the Fon on its IP - either 192.168.1.1 for Fon+ or Fon2, 192.168.1.254 for Fon. By forcing the windows box to be on the 192.168.1.22 IP can you now try to flash the Fon.

The other reason the flash may be failing if you are on the 192.168.1.0 subnet is because you moved redboot off onto another IP address. This seems unlikely as it kind of advanced redboot manipulation but it is possible if you accidentally fiddled in the wrong area. The last test I gave would tell you if redboot is listening on the expected IP. Doing this test right is quite important or you will get bad results. Get the ping going and power on the Fon. As soon as the Fon starts, literally as the power comes on, if redboot is listening you will get a few, usually 4 for me, ping results back, then it will go dead again for a while then you may get ping responses again. The first 4 are from redboot and show that it is listening on that IP, the rest are from the OS once the device is booted. The second lot can be ignored, we know the OS is on 192.168.1.1 we are looking for what IP redboot is on and that can be completely different to the OS. That is why only the first 4 or so ping responses as soon as the device is powered on are important.

Link to comment
Share on other sites

Hi digininja,

Thank you for your replies,

I have set my laptop's NIC card to

IP= 192.168.1.22

subnet: 255.255.255.0

DG: 192.168.1.1

Without launching Freifunk Ap51 Easyflash, I wanted to do a test.

I plugged in my FON's network cable to my laptop's LAN NIC.

I launched "ping -t 192.168.1.1"

Destination host unreachable

Destination host unreachable

Destination host unreachable //powered my fonera ON

Destination host unreachable

Destination host unreachable

Destination host unreachable

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out //got a message saying that network cable is unplugged.

Request timed out

Request timed out

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Request timed out

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

.....

stopped the ping process.

powered my Fonera OFF.

Second Test

I opened Freifunk Ap51, chosen my files and the interface (did not click on GO yet)

launched "ping -t 192.168.1.1"

Powered my Fonera ON

Clicked on GO from Freifunk

Destination host unreachable

Destination host unreachable

Destination host unreachable

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out //got a message saying that network cable is unplugged.

Request timed out

Request timed out

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

Reply from 192.168.1.1 bytes=32 time=1ms TTL=64

I browsed to 192.168.1.1 with my browser and got Jaseger page.

Now I started to think if my files are bad, but I extracted them from Darren's zipped file.

Rootfs: openwrt-atheros-2.6-root.squashfs

Kernel: openwrt-atheros-2.6-vmlinux.lzma

And the messages I see on Freifunk are like I mentioned above

Reading rootfs file C:\openwrt-atheros-2.6-root.squashfs with 1179648 bytes...

Reading kernel file C:\openwrt-atheros-2.6-vmlinux.lzma with 786432 bytes...

rootfs(0x006e0000) + kernel(0x000c0000) + nvram(0x00000000) sums up to 0x007a0000 bytes

No packet

No packet

No packet

Peer MAC:

Peer IP: 192.168.1.254

Your MAC:

Your IP: 192.168.1.0

Link to comment
Share on other sites

Try doing the ping on .254 instead. The Fon 2100 can start redboot on there which is what the last couple of lines of your post are implying when it says the peer is on .254.

I don't understand why it says

Your IP: 192.168.1.0

though. Any Freifunk users out there know if this is normal?

Link to comment
Share on other sites

Ok,

The IP on my NIC is still 192.168.1.22

I started "ping -t 192.168.1.254"

Launched Freifunk, pressed GO and powered my fonera ON

Destination host unreachable

Destination host unreachable

Destination host unreachable

Destination host unreachable

Destination host unreachable

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Reply from 192.168.1.254 bytes=32 time=1ms TTL=64

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Request timed out

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

Reply from 192.168.1.1 Destination host unreachable

.....

if I open my browser, go to 192.168.1.1, I get "Jaseger" page.

Link to comment
Share on other sites

OK, you are still missing the fundamental point of redboot, it isn't the OS and has nothing to do with it. Redboot is some software that loads, runs, listens for connections then loads the OS into memory and finally runs that. It isn't the OS and has nothing to do with the networking from the OS. Because of that its IP address can be completely different. You can set the redboot IP to 123.123.123.124 if you want to and the OS will still come up on 192.168.1.1, similarly you can set the OS to 10.1.1.1 and redboot will stay on 192.168.1.254.

So, now we have established that redboot is running and that its IP address is 192.168.1.254.

I've never used Freifunk but it appears that your problem is somewhere in there. All I can think of is try setting your PC to have the IP address of 192.168.1.1 then try the flash. Make sure you use it in the right order, my guess for the order is to set it up, click go then power on the Fon but that might be wrong. Check the docs and the website for info.

Link to comment
Share on other sites

When I assigned 192.168.1.1 on my laptop and started to flash, it did not work also. Can you please let me know what should I expect?

We know that the redboot is running and that its IP address is 192.168.1.254. But why does it drop to 192.168.1.1? again?

After I see lines below, what would I see? How long does it take to see the next lines?

Reading rootfs file C:\openwrt-atheros-2.6-root.squashfs with 1179648 bytes...

Reading kernel file C:\openwrt-atheros-2.6-vmlinux.lzma with 786432 bytes...

rootfs(0x006e0000) + kernel(0x000c0000) + nvram(0x00000000) sums up to 0x007a0000 bytes

No packet

No packet

No packet

Peer MAC:

Peer IP: 192.168.1.254

Your MAC:

Your IP: 192.168.1.0

Thank you

Link to comment
Share on other sites

It "drops to 192.168.1.1" again because the flashing app isn't managing to access redboot so the boot process is continueing past redboot and you are booting into the OS which has the IP of 192.168.1.1.

Why it isn't working I've no idea, I'll have to hand you back over to other forum users who know more about flashing in Windows that I do.

Link to comment
Share on other sites

I did not hear anything else from other forum users.

Do you think if I purchase Serial USB cable which is mentioned in the forum, can it be a solution to my problem?

Or the time my FONERA boots with the IP 192.168.1.254, do I need to do something quickly before it drops to 192.168.1.1 again?

Thank you

Link to comment
Share on other sites

If you have access to a linux box then try reflashing it with redboot. Full details for that are kicking around somewhere in the forums and on my site in the Interceptor section under the full walkthrough section.

Link to comment
Share on other sites

OK, so I thought i too bricked my fon router. I had to abruptly stop in the middle of my firmware flashing, and it was extremely hard to get back up and working. So digging through some of the forums, I was able to get my Jasager up and working. :)

Here's what I did.

I set my IP address of my Local Area Connection to 192.168.1.22.

I found that I wasn't able to ping 192.168.1.1, but I was however able to ping 192.168.1.254. When I ran NMAP against it, the only port that it showed was TCP 9000.

I downloaded:

Freifunk Ap51 EasyFlash GUI utility

openwrt-atheros-2.6-vmlinux.lzma and

openwrt-atheros-2.6-root.squashfs

Unplug your router.

Open Freifunk, and load the the two files listed below.

Hit GO!

Now plug back in your FON router, and wait. It should start connecting and then show you are flashing.

Give that a shot, it worked for me.

Link to comment
Share on other sites

  • 2 weeks later...

Yes, it is working now. Thank you digininja and everyone.

I do not know what was the real cause, I tried it on my Vista, it did not work. I tried on XP it did not work. Then at the end, I tried on another XP machine and it started to flash. I am all set and soooo happy.

Thanks again

Link to comment
Share on other sites

  • 2 weeks later...

I got my SSID back to normal. My Fon 2100 never had WPA, it say's "Unsecured Network"

For some reason I never could connect to 192.168.10.1, but I was able to connect to 192.168.1.1. Not anymore. The last thing I remember doing was changing my openwrt setting to dhcp with an ip of 192.168.0.250. I tried using the wired but still not connecting.

I'm running windows Vista hp pavilion dv9700 PC with 32-bit OS with Atheros Ar5007 802.11 b/g and Norton Internet security 2009.

Link to comment
Share on other sites

For some reason I never could connect to 192.168.10.1, but I was able to connect to 192.168.1.1. Not anymore. The last thing I remember doing was changing my openwrt setting to dhcp with an ip of 192.168.0.250. I tried using the wired but still not connecting.

I don't remember anywhere allowing you to set a default IP to go with DHCP but I could be wrong, I never use the web interface. Do you remember setting one or the other? If you set it to DHCP do you have a DHCP server running to give it an IP address?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...