Jump to content

Mother-fracking god damn Ndiswrapper... (help needed)


VaKo
 Share

Recommended Posts

So i decided to try linux again, and since Suse was the only one that I liked, i went with the latest (10.1) version of openSuse. It seems to work fine, and I've already learn a bunch... just not enough it seems....

Spent all day trying to get ndiswrapper to work, followed this guide to the t, and nothing. It installs, the command ndiswrapper -l shows the card, i've setup a network device in yast for it but it still won't connect. I'm using a Dell Latitude x300 with a Dell Wireless 1450 Dual Band miniPC card...

Can anyone help me out here with a complete idiots guide to getting wifi working in linux? There's a pint in it...

Link to comment
Share on other sites

I'll give it a whirl, thanks...

But FFS, you would have thought that Suse & Redhat would have enough clout to demand wifi support. Suse looks fucking awsome, works like a treat but this lack of wireless kinda makes it a complete waste of time.

Link to comment
Share on other sites

cd /windows/C

look for a folder named "DRIVERS" in here. It will contain the win driver files you seek. You'll be looking for a .inf file under /DRIVERS/WIRELESS or /DRIVERS/NET or similar location.

cd DRIVERS/path/to/inf/file

cp *.inf /

cp *.sys /

cd /

ndiswrapper -l

(erase any existing entries)

ndiswrapper -e entry1

ndiswrapper -e entry2

ndiswrapper -i /filename.inf

ndiswrapper -m

ndiswrapper -hotplug

modprobe ndiswrapper

Make sure we see positive results.... do we show a registered wifi device?

iwconfig

Quick n dirty:

Open wifi:

iwconfig wlan0 essid (YourNetworkName) mode managed

WEP:

iwconfig wlan0 essid (YourNetworkName) mode managed key (hexKey)

dhcpcd wlan0

if successful; you can now surf the intarweb. You can also let YaST do the "quick in dirty" things for you, but YaST will not "just see" your wireless device. You will have to add a new entry, and put "ndiswrapper" in as the module. WPA is another ballgame, one I haven't fooled with yet with ndis. So you can Google that up, or change your router from WPA back to WEP.

Your choice of distro is right -- stick to it.

Link to comment
Share on other sites

In the end I just tried the built in network manager, not the CLI stuff suggested in the tutorials.

My inital impressions of Suse 10.1... its damn good, better than XP... but not quite as polished as XP if you know what I mean. Still not n00b friendly yet, but a lot better than last years, and the installer kicks the ass off of XP and ubuntu. I'll compare it with Windows Vista and do a review. Linux on the desktop has come a long way, but still not there yet.

Link to comment
Share on other sites

I just went through the ordeal of getting wireless (WPA) working on my laptop with Ubuntu (6.06). My main issue was getting the drivers for my broadcom minipci wireless card working. The other issue was finding a way to use WPA. I ended up installing the new version of network manager (https://wiki.ubuntu.com/NetworkManager) and this worked like a champ. I am not sure if it will work with SUSE (I have not worked with suse in a few years) but it is worth a look.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...