Jump to content

exec4

Active Members
  • Posts

    40
  • Joined

  • Last visited

Everything posted by exec4

  1. Hello timmr, I'd also like to see that. Maybe @Foxtrot can tell somethingabout it?
  2. This should now work on the MK7 with Firmware 1.1.0 too.
  3. So I also have one AWUS036ACM. After changing to WLAN3 I can select 5Ghz on the "Recon" page, but have never seen any assistant showing up, nor am I able to start a 5Ghz Hotspot. Go to Settings -> Networking and select "wlan3" as "Recon Wireless Interface"
  4. So now after installing firmware 1.1.0, i am able to use USB tethering. After running opkg install kmod-usb-net-rndis opkg install kmod-nls-base kmod-usb-core kmod-usb-net kmod-usb-net-cdc-ether kmod-usb2 according to the OpenWrt user guide it's working and not rebooting.
  5. Please share some more information. How do you connect?
  6. I could not find anything in the docs, but I remember it should have at least 2A at 5V.
  7. So I tried following, using beta 2 at the moment. Connect a powered hub to the Pineapples USB A port, with a "Charger doctor" in between to measure power consumption - there is none at any time in this test. When I connect the USB adapter, following happens: [ 470.704765] usb 1-1.3.4.4: new high-speed USB device number 7 using ehci-platform [ 471.220788] RTL871X: rtw_ndev_init(wlan3) [ 472.043740] IPv6: ADDRCONF(NETDEV_UP): wlan3: link is not ready Now I disconnect the adapter. The blue LED on the pineapple turns off, the power on the USB A port on the drops to 0v. It automatically reboots and is online after about 30 seconds, but there is no Any ideas? Thank you in advance.
  8. Hello @chrizree Actually it worked after "echo c > /proc/sysrq-trigger", but not after it was crashing while using the AWUS! Strange. Don't have an actively powered usb hub at the moment, will try that later again.
  9. Hello Foxtrot, I was able to install the kmod for my AWUS036AC, and it looks good at first. I run "watch -n 0.1 dmesg" and connect it, everything seems fine, I can see some messages for wlan3. But when I use wlan3 to scan for networks, the Pineapple immediately reboots, I can't even see anything on dmesg output. is there a way to get my crash dump, or to see there is none and it might be a power fault? My Laptop's USB C schould at least support 2A, and I also think I already tried with an actively powered USB Hub. Thank you.
  10. Hello, that sounds nice, I will try that asap.
  11. Hello Hike, my 64GB USB 3 thumbdrive gets mounted automatically! /dev/sda1 on /usb type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096) Maybe connect it to a computer and check the file system? Please post the output of dmesg. Edit: I just realized you try to mount an NTFS filesystem using `-t ext4`, ext4 is a total different file system actually.
  12. Hello, I tried that with opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk --force-depends opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk --force-depends But it resets immediately.
  13. Hello Foxtrot, that sounds nice. I don't understand the difference between the two options, but will try asap. Maybe this could be added as feed later?
  14. That sounds awesome! Actually with firmware 1.0.0 I do have the same problem: root@mk7:~# opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk Installing kmod-usb-net-cdc-ether (4.14.180-1) to root... Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-net-cdc-ether: * kernel (= 4.14.180-1-d92769dc5268e102503ae83fe968a56c) * opkg_install_cmd: Cannot install package kmod-usb-net-cdc-ether. root@mk7:~# opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk --nodeps Installing kmod-usb-net-cdc-ether (4.14.180-1) to root... Configuring kmod-usb-net-cdc-ether. Connection reset by 172.16.42.1 port 22 I
  15. Thanks for your offer, looking forward to contact you tomorrow or maybe next week. I tried your package with the same result. Maybe I need to downgrad to firmware 1.0.0 from beta? I will try that now.
  16. Hello, Thank you. I tried that, but root@mk7:~# opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk Installing kmod-usb-net-cdc-ether (4.14.180-1) to root... Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-net-cdc-ether: * kernel (= 4.14.180-1-d92769dc5268e102503ae83fe968a56c) * opkg_install_cmd: Cannot install package kmod-usb-net-cdc-ether. root@mk7:~# opkg install kmod-usb-net-cdc-ether_4.14.180-1_mipsel_24kc.ipk --nodeps Installing kmod-usb-net-cdc-ether (4.14.180-1) to root... Configuring kmod-usb-net-cdc-ether. After that, the mk7 just reboots...
  17. Actually I don't understand why I cannot install kmod-usb-net-rndis It's in the base packages, I run opkg update opkg install kmod-usb-net-rndis The package is not found... also I cannot find it using opkg search opkg list | grep rndis
  18. Can you ping your computer from tje pineapple? Please post the ip config of your pineapple while your are trying to connect.
  19. Hello Aaron, I am not looking for the easiest way, and I am willing to try and fail, in order to learn.
  20. Helllo, has anybody here created a toolchain for the mk7 yet? I have build for my nano with the help of the github repository, but there is no source for the mk7 OpenWRT base system. Thank you
  21. Exactly, and that was the question. If I had problems with power consumption, I would just put an active USB hub between the Pineapple and my Smartphone. I will search opkg for a kmod.
  22. Hello, thanks for your replies. Actually I could connect without the app, that's no problem. The problem is, that the pineapple mark 7 doesn't create a network interface, so it's just charging my phone...
  23. Hello, I really liked I could just connect my android phone, enable usb tethering, and use it as internet with my nano. On my MKVII, I can enable it on the phone, but according to dmesg and ip link, no device is being created. Are there any plans to implement that in the near future? Thank you
×
×
  • Create New...