Jump to content


Photo
- - - - -

Armitage Connection Reset


  • Please log in to reply
7 replies to this topic

#1 nomadpenguin

nomadpenguin

    Newbie

  • Members
  • 1 posts

Posted 18 September 2011 - 02:52 PM

I am trying to use armitage on bt 5 r1
when i hit "start msf" it tells me "connection refused", then "using postgresql" then, "could not connect to db, make sure it's running" Looking at the terminal, it tells me that the connection was reset. I realize that there has been a previous thread on this, but the problem was not solved. Thanks in advance!

#2 Mr-Protocol

Mr-Protocol

    Hak.5 Packet Ninja

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,448 posts
  • Gender:Male

Posted 18 September 2011 - 08:18 PM

Not sure what your issue is. It should be using mysql instead of postgresql.

Made this for your understanding:


You may need to right click the video and watch on YouTube so you can full screen.

Edited by Mr-Protocol, 18 September 2011 - 08:19 PM.

Mr-Protocol @ irc.hak5.org #hak5
Mr-Protocol @ chat.freenode.org #hak5
 
https://wifipineapple.com/
 
Im just watching a bad dream I never wake up from. -Spike Spiegel
DerbyCon


#3 Infiltrator

Infiltrator

    Gray-Hat Specialist

  • Active Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 4,392 posts
  • Gender:Male
  • Location:Over the Atlantic, at a cruising altitude of 70.000 feet.
  • Interests:Wireless and Network Security
    Server Virtualization
    Computer Network Infrastructure
    Server implementation.
    General Aviation
    RC Airplanes and Helicopters
    Scuba Diving
    Sky Diving
    War driving
    Solar battery Systems.
    Pen-Testing
    Command & Conquer

Posted 20 September 2011 - 12:07 AM

Here is how to

http://vishnuvalenti...in-backtrack-5/
Regards,
Infiltrator


Posted Image

Currently studying for my CCE.

#4 Mr-Protocol

Mr-Protocol

    Hak.5 Packet Ninja

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,448 posts
  • Gender:Male

Posted 20 September 2011 - 12:28 AM

Here is how to

http://vishnuvalenti...in-backtrack-5/

The video I made for my post makes it as easy as you can get.

cd /pentest/exploits/framework
ls
./armitage

Click "Start MSF" and wait for it to load...

Mr-Protocol @ irc.hak5.org #hak5
Mr-Protocol @ chat.freenode.org #hak5
 
https://wifipineapple.com/
 
Im just watching a bad dream I never wake up from. -Spike Spiegel
DerbyCon


#5 Infiltrator

Infiltrator

    Gray-Hat Specialist

  • Active Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 4,392 posts
  • Gender:Male
  • Location:Over the Atlantic, at a cruising altitude of 70.000 feet.
  • Interests:Wireless and Network Security
    Server Virtualization
    Computer Network Infrastructure
    Server implementation.
    General Aviation
    RC Airplanes and Helicopters
    Scuba Diving
    Sky Diving
    War driving
    Solar battery Systems.
    Pen-Testing
    Command & Conquer

Posted 20 September 2011 - 06:16 AM

The video I made for my post makes it as easy as you can get.

cd /pentest/exploits/framework
ls
./armitage

Click "Start MSF" and wait for it to load...


I agree and didn't say your video was useless, was just trying to show him other options to help him out too.
Regards,
Infiltrator


Posted Image

Currently studying for my CCE.

#6 555

555

    Hak5 forum junky

  • Active Members
  • PipPipPipPipPipPip
  • 418 posts
  • Gender:Male

Posted 03 October 2011 - 12:20 PM

I appriciate both of the information, the more the better. I have been fiddling with Armitage also, thanks.

#7 rsmudge

rsmudge

    Newbie

  • Active Members
  • 3 posts

Posted 03 October 2011 - 05:28 PM

@nomadpenguin You shouldn't use MySQL with Armitage. The Metasploit team uses postgresql. Also, there is a known issue where Metasploit updates fail to update the db tables properly when MySQL is in use. Armitage and Metasploit work with BackTrack 5 out of the box.

Postgresql should always be running by default on BackTrack 5. If it's not (hence the "is the database running message?"), then you need to get it running. Type:

/etc/init.d/framework-postgres start

It'll either start or you'll see an error message. If you see bogus data in lock file "postmaster.pid" then you'll need to type the following:

rm /opt/framework3/postgresql/data/postmaster.pid
rm /opt/framework3/postgresql/.s.PGSQL.7175
rm /opt/framework3/postgresql/.s.PGSQL.7175.lock

/etc/init.d/framework-postgres start

[See: http://www.backtrack...elp-please.html for the original thread on this issue].

Also, Armitage has a nice Help button in the setup dialog now. Click that button to see every possible thing that I know can go wrong (and what the corresponding remedy is).

#8 digip

digip

    -we're all just neophytes-

  • Active Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 7,655 posts
  • Gender:Male
  • Location:RnVjayBPZmYh 192.168.100.1

Posted 03 October 2011 - 07:07 PM

@nomadpenguin You shouldn't use MySQL with Armitage. The Metasploit team uses postgresql. Also, there is a known issue where Metasploit updates fail to update the db tables properly when MySQL is in use. Armitage and Metasploit work with BackTrack 5 out of the box.

Postgresql should always be running by default on BackTrack 5. If it's not (hence the "is the database running message?"), then you need to get it running. Type:

/etc/init.d/framework-postgres start

It'll either start or you'll see an error message. If you see bogus data in lock file "postmaster.pid" then you'll need to type the following:

rm /opt/framework3/postgresql/data/postmaster.pid
rm /opt/framework3/postgresql/.s.PGSQL.7175
rm /opt/framework3/postgresql/.s.PGSQL.7175.lock

/etc/init.d/framework-postgres start

[See: http://www.backtrack...elp-please.html for the original thread on this issue].

Also, Armitage has a nice Help button in the setup dialog now. Click that button to see every possible thing that I know can go wrong (and what the corresponding remedy is).

Nice to see you on the forums and nice to meet you this past weekend. We really got a kick out of your Red vs Blue talk and "Q: how did you get in? A: Default passwords, default passwords, ms08-67 and default passwords.."

:)
@xxdigipxx http://www.attack-scanner.com/ | I'm the resident dick around here, or so I am told. Don't take it personally, I just give a shit too much sometimes. respect to all, its the Internet, don't take it to heart.
"Staying quiet doesn't mean I have nothing to say, it means I don't think you're ready to hear my thoughts..."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users