Jump to content

Unable to execute mdk4 from command line


Recommended Posts

Hi there

I installed mdk4 package on my pineapple enterprise and tried to execute mdk4 from the terminal window. It says  "command not found" although opkg says that it is installed. 

Any help and advice is highly appreciated

Link to comment
Share on other sites

If "which" doesn't report anything back, then I would argue that mdk4 isn't installed at all. In what way did you install it? I assume from CLI using opkg as you say that opkg reports that it has been installed. I'm not using the Enterprise version, but it should be the same procedure as the Mark VII.

Link to comment
Share on other sites

I tried:

a) Installing the module and then waiting for the request to confim installation of the dependencies - afterwords check in GUI that package is displayed as installed

b) remove module and package (opkg) and install package via CLI with opkg check in GUI and with opkg that it is installed 

.... but at the end - it seems that it is not where it should be ... 

Strange - a package where the package manager says it is installed when it isn't ....

I also did a factory Reset and recovery as described in the manuals - no sucess.

Any ideas?


Link to comment
Share on other sites

Must be Enterprise specific then. I have no issues installing it either using CLI or the module manager of the Pineapple web UI on the Mark VII (which should be transparent regardless if it's the Mark VII or the Enterprise, but it might have changed lately, or I might not remember it correctly).

Link to comment
Share on other sites

I made some further checks and found that the ipk from enterprise repo (https://downloads.hak5.org/pkgs/ent1/stable/2.1.0/packages/mdk4_4.1-2_arm_cortex-a7_neon-vfpv4.ipk) does not contain the binary. 

No wonder it doesn't work - another problem is that opkg processes this package and says it is installed when the neccesary binary it is not included at all.

Does anyone have an idea where i can get a working binary for this architecture ?


Link to comment
Share on other sites

really, really disappointing - opened a ticket at hak5 to inform them that the package on the repository provided by hak5 if defect and does not contain a binary .

What came back is - we do not provide support to payload etc.  .... 

Obviously at hk5 nobody there is interested to fix obvious bugs. That is really not what one would understand in profesionally supporting an "enterprise" tool and the paying customers 


PS: just to be clear - my question was not about how to use mdk4 or about the packages functionality in a specific case - it was just about fixing a very clear problem within a repo hosted by the product manufacturer

Link to comment
Share on other sites

  • 4 weeks later...

I have now tried many things in the last weeks -. 

- open ticket at hak5 -> no result - see above
- ticket in github - > no response
- mail to @Darren Kitchen with description of the problem and request for remedy - no response so far 

Is it really the case that almost nobody uses the enterprise version and that the problem therefore does not occur anywhere?

Link to comment
Share on other sites

I'd say there isn't a quazzillion users of the Enterprise Pineapple out there, but that's just a qualified guess and most likely due to the pricing. The common user is likely business customers that aren't that active on the forums for different reasons.

In any way, you've gotten an answer. MDK4 isn't a part of the Pineapple framework even though it's listed (but empty) in the repo. This is probably a "heritage" from the Mark VII. Hak5 most likely included some tools as an extra treat (among those; MDK4) for the Mark VII and this followed along to the Enterprise (but has clearly not been fully implemented). There's nothing that says that Hak5 should provide MDK4 though. I haven't seen that being stated anywhere.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...