Jump to content

Red blinking (Error - no payload found) after cp some_other_payload.sh to payload.sh


Recommended Posts

After copying another payload to payload.sh (cp some_other_payload.sh payload.sh) and rebooting the Shark Jack, the led is blinking red which means: "Error - no payload found". This has happened before and reinstalling the latest firmware did solve the issue back then but as I have quite some additional packages installed like: nano, curl, llpdp bind-*, openssl etc. and also installed a couple of lookup files e.g. for arp-scan, it is not convenient to run into this blinking red situation over and over again.

Are there others facing similar issues and is there a quick fix to get the issue solved?

Note: in my main payload script I am running a background task which syncs the filesystem every 5 seconds, could this be the root cause for the issue?

function SYNC_FS() {
    while true; do
        sleep 5


Thanks in advance.

Link to comment
Share on other sites

  • 3 weeks later...

Do you have a single "payload.sh" file in the payload directory, or do you have several files in that directory? I got pretty much the same result when having a "payload.sh" file along with a "payload.sh.org" file in the payload directory. After removing the additional ".org" file, the payload executed as expected. Try again with a "clean" payload directory containing only one (1) file, i.e. only the "payload.sh" file, nothing else. According to your post, it seems as if you have just one file in the payload directory. I just wanted to post this suggestion since I ran into a similar situation.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...