Jump to content

Router Config Help


Brennan
 Share

Recommended Posts

I have a Linksys WCG200 and have been having trouble with getting my router to work with my server. and yes I did the port forwarding dropped the firewall and still nothing. It works when I go to my address http://redwind.hopto.org but when I ask my friend to go to it he always gets server took too long to reply. and it times out for ftp.

if you need screen shots i will post them.

Link to comment
Share on other sites

What OS is your FTP running on? Did you open the ports on the server machine itself? Somewhere it seems you might have missed something. I scanned the server and it shows no ftp running. (I could be wrong) If your running XP you need to add the port to the firewall which you probably already know and also the advanced tab -> select adapter in use for ftp -> settings and check FTP Server. At least if your using IIS that should work unless you have any other 3rd. party firewalls running also.

Hope that helps.

Link to comment
Share on other sites

What OS is your FTP running on? Did you open the ports on the server machine itself? Somewhere it seems you might have missed something. I scanned the server and it shows no ftp running. (I could be wrong) If your running XP you need to add the port to the firewall which you probably already know and also the advanced tab -> select adapter in use for ftp -> settings and check FTP Server. At least if your using IIS that should work unless you have any other 3rd. party firewalls running also.

Hope that helps.

I am runing XP for now and droped its firewall but I will put everything back up as soon as I know it works without it and I do have the ports 80 and 21 forwarded to my server

ive heard there is problems with using ports other than 80 when using a free urls. Also i was unable to see ur site all together (could be coz ur off lol) but try FTP'ing to the IP address not the url.

I am using port 80 and I also contacted my ISP and asked if they block the ports I need. And my internet droped last night for about 30min so you might have tried then

Is that was that is? A hosting site? Don't i feel dumb now Embarassed I was assuming he was running his own server only cause that's the only way i would do it and am use to Smile

No its not a hosting site I am running my own server

Link to comment
Share on other sites

First of all, getting free "URL" is simply Dynamic DNS. It changes whatever your hostname (bob.something.com) to 68.65.97.78 or whatever. So that is not blocking it.

Second. What is your ISP? Many ISPs such as Adelphia, Comcast, Verizon and others, block personal web hosting by blocking port 80 at their boundries. To check for this, switch the port in your port forwarding rules on your router from 80 -> 80 to 85 -> 80. What this does is, with the minimal change on your router allow people to connect to http://bob.something.com:85/ and actually get to your web server, without any changes to the server itself.

If that doesn't work. Try putting your server in your routers DMZ. Check again for connectivity to http://bob.something.com:85. If this still doesn't work. Go to grc.com and go into shields up. click on their all services scan. (https://www.grc.com/x/ne.dll?bh0bkyd2). Check what ports are open.

If all of this doesn't work, then your ISP is screwing your by blocking all possible service hosting. Pack up, clean your forwarding rules, take your server out of the DMZ and turn Windows firewall back on. Then start looking for either a different ISP or a hosting company.

Link to comment
Share on other sites

OK i found the prob with the http (asshole lied to me) they block all service ports except 21. but now my question is wuts wrong with my FTP

FTP sucks, use HFS or SFTP. HFS (HTTP File Server) is easy to use and SCP uses SSH making it secure.

Link to comment
Share on other sites

OK i found the prob with the http (asshole lied to me) they block all service ports except 21. but now my question is wuts wrong with my FTP

Also something that took me awhile to figure out that you have to in the adapter properties --> advanced tab --> settings button for firewall --> advanced tab in firewall settings --> select adapter in use for server and you have to check FTP Server and HTTP Server if your doin HTTP also. It seems that in XP SP2 you have to do that for each adapter for it to work properly.

Then since your runnin your own server open up IE or FF or whatever you use and do a http://localhost... actually are you using IIS? This method will work fine for IIS I haven't used anything else so not sure if it'll work with any other type of FTP server/software.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...