Jump to content

Modules not working


Bob123
 Share

Recommended Posts

I don't want to hijack the nano truth thread anymore so I'll start something here in hopes that we can clear up some confusion.  First my background so I can get a better understanding of what's going on, cause I'm not really having issues here...but...I don't typically upgrade my devices unless I have a reason to.  I don't just upgrade to upgrade.  So what are the problems we're having with the bunny, turtle, duck, and pineapple?  I've tried to help several people on the turtle, bunny, and duck without much luck because my firmwares are older and theirs are the latest and greatest, or at least they are trying to put the latest firmware on theirs.  Cap_Sig says it's third party apps that need to be upgraded and I can buy that.  Are these apps breaking because of Hak5 firmware upgrades or because people are upgrading the actual Linux software on their devices?  As far as I'm aware these are two different things.  Please correct me if I'm wrong.  I'd like to help, I'd like to upgrade the firmware on some of my devices but hearing the issues after upgrading...I'm not so sure I want to.  So where do we go from here?  Any info would be great.

Link to comment
Share on other sites

So on the topic of the Wifi Pineapple Tetra and Nano.  The issues users are having is with community modules.  To explain to anyone not familiar, "community" modules are exactly that, modules made by community users to add features to the pineapple that is not included with the core firmware.  Due to the recent update to firmware 2.6.x the OpenWRT version was upgraded several versions ahead of the last prior pineapple firmware version 2.5.4 from 15.x to version 19.x in the pineapple firmware.  Due to this nearly all modules and any required dependencies for them to work need to be updated as well so they are compatible with pineapple firmware 2.6.x

Now this is frustrating waiting for the community modules to be updated, BUT the pineapple is not sold with the promise of any of these community modules.  The wifi pineapple firmware 2.6.1 I can confirm working on the Tetra.  Core features like Recon and PineAP that are part of the Hak5 released firmware are working (may have minor bugs that will be updated in future firmware but are still at this point functional) which is what you are buying directly from Hak5.

It is my opinion that nearly all current complaints are on the topic of community modules not working due to the update to 2.6.x.  So again, it is frustrating to some level that modules you'd like to use will not work on the newest firmware BUT it is not fair to say as some users that Hak5 products are "junk" or that they are "ripping people off".  I think like always the Hak5 team and community will work together so that things will be smooth sailing again but it does take some time.  The only real issue is if a community module developer is no longer active someone else will have to take on the task of fixing it.

For anyone looking to see the status of tested modules take a look here: 

If you have any info on a module and the status of it working/not working please post to the above thread to help keep a log until all these community module issues are resolved!

Link to comment
Share on other sites

Would the same be true with quickcreds and openvpn modules on the bash bunny and lan turtle?  I tried to help others months ago and their brand new bash bunny and lan turtle wouldn't work yet mine seemed to work right from the get go.  These are older modules and I guess I don't remember having issues back in the day when they were first popular but my firmware is also several revisions older than what's out there now.  And I never did find out if it was a firmware issue or and update to the linux software.  I've noticed a lot of people doing software updates on their devices "apt-get" and I'm curious why that would ever been necessary.  Apt-get one piece of software sure but apt-get upgrade just to do it???  Why?

Link to comment
Share on other sites

@Bob123 I can't really say much on the bash bunny side of things as I haven't used them much recently.  Payloads should remain functional through firmware versions as long as a dependency or syntax change doesn't occurs, but it is possible for firmware updates to cause the issue if so. One common issue I have seen with the bash bunny payloads is users not configuring them correctly or they payload not be compatible to work on the user target system.  Depending on the configuration of the target system a payload may not work at all.  For example, some payloads can be blocked by admin settings on for say a Windows 10 system.

12 hours ago, Bob123 said:

I've noticed a lot of people doing software updates on their devices "apt-get" and I'm curious why that would ever been necessary.  Apt-get one piece of software sure but apt-get upgrade just to do it???  Why?

This is a long debated topic.  I think it really goes both ways depending on the situation.  If you have a direct need from a system and have it working the way you want, don't risk updating unless you are for sure the update is confirmed working or you have a reason to update.  But on the other side, if a system is used in general it is best practice to update for improvements and patches you may be unaware of.  I'm sure this could be debated for days but when it comes down to it, do whats best for you and your needs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...