Jump to content
SYNACK21

HELP PLEASE! NANO, Kali VM can

Recommended Posts

I purchased a NANO Tactical kit about year ago. I finally had some time today to try and set it up. I installed the new release. I followed all instructions per Darren. I got it working perfectly on my laptop using just my Windows 10 OS. I was able to log into the NANO and Download Bulletins from WiFiPineapple.com and Modules.

PROBLEM STARTS
The problems starts when I wanted to use my NANO on my Kali VM (Virtual Box). I went through the steps to get it set up using the wp6.sh script. I was able to successfully connect to my NANO with the link at the end that shows "Browse to http://172.16.42.1:1471". I am able to click on that link which opens up an internet page prompting with the login screen to my NANO. I enter my password and I am able to get in, but when I click on Load Bulletins from WiFiPineapple.com I get the following error "Error connecting to WiFiPineapple.com. Please check your connection" I also get the same error if I go to Modules and try to click Get Modules.

TROUBLESHOOTING
So to test I successfully SSH to my NANO and tested a couple connections. I am able to ping my following IP addresses 172.16.42.1, 172.16.42.42, 172.16.20.1 which is my gateway to the internet. I am also able to Ping WiFiPineapple.com with successful responses. I tried a traceroute to WiFiPineapple.com and I see 30 successful hops going to the Destination of WiFiPineapple.com. #1 hop is 172.16.42.42. #2 hop is 172.16.20.1 and rest of the hops are all public IP internet hops all the way until it reaches WiFiPineapple.com @ 104.18.51.22. I don't understand why I can reach WiFiPineapple.com from the NANO through SSH but not through the GUI interface. I can also open up a browser window and goto WiFiPineapple.com website without issue. This has me stumped. I been working on it for last 3 hrs, but I am finally reaching out for some help. Has anyone else ever had this issue? If I could please get some help I would greatly appreciate it. I am not a NOOB at any of this so no need to be treated as such. I hope someone out there has a remedy for this! Thanks in advance for any help is received.

Share this post


Link to post
Share on other sites

1.  Do you know your gateway for your router?

2.what option did you use for wp6.sh to setup the internet connection?

3. Check your settings on the kali VM to make sure its not setting the pineapple as your default connection for internet for the VM 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...