Jump to content

Linux wlan0 Problem


MRGRIM
 Share

Recommended Posts

Hello

I've bought a Netgear MA111 for the purpose of cracking wep keys as I though it looked intrested. I am a complete Linux novice (having only ever set a SAMBA server up) so I've downloaded the Auditor and am booting off the CD. I've been playing round with Kismet etc following some instructions I've found online however I belive I need to set my wireless adapter into monitor mode I belive I can do this by running 'iwconfig wlan0 mode monitor; when I do this I get the following error message 'Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Operation not supported.'

Being a novice I don't know how to resolve the issue or where to possibly start, I've had a look at some google groups but its awfully scare as they keep telling people to recompile things :shock: does anyone have any suggestions?

Regards

Link to comment
Share on other sites

If your wireless card isn't supported you could always use ndiswrapper to make it run using the windows drivers, but for a novice this is going to be the difficult route to take. Even if you did get your card to work using ndiswrapper it won't be capable of running in promiscuous mode, which is what you need it to do.

Link to comment
Share on other sites

Post your output from the command: iwconfig

most wireless cards that show up as wlan0 create two devices. I don't know why, it's just something you live with. So you can try setting eth1 to monitor. Also, try using airmon.h to set your interface to monitor mode. just hit airmo and hit tab to make sure that is the right one.

Link to comment
Share on other sites

For me and my prisim adapter (Senao 2511) to set it to monitor mode and have it working properly I had to downgrade the firmware then to set it to monitor mode I used:

ifconfig wlan0 up

airmon.sh start wlan0

iwconfig wlan0 mode monitor

something you might try also a very good resource for WEP cracking checkout

http://forums.remote-exploit.org

Link to comment
Share on other sites

  • 3 weeks later...
most wireless cards that show up as wlan0 create two devices.

Also, try using airmon.h to set your interface to monitor mode. just hit airmo and hit tab to make sure that is the right one.

I have 3 devices listed, eth0, lo and wlan0. I am using a live cd version of Auditor, when I type airmo or airmon.h it says "command not found"

ifconfig wlan0 up

airmon.sh start wlan0

iwconfig wlan0 mode monitor

Again when I tried airmon.sh "command not found"

Quite depressing!

Link to comment
Share on other sites

  • 3 weeks later...

fwiw

i had a hell of a time getting kismet to work with my orinoco gold card until i downloaded knoppix-std and then it worked first time.

the major problem wiith the orinoco is that it has limited range for cracking wep.

sdduming you are trying it at home you cant exactly hang your laptop out the window,

ideally you want a usb adaptor with an extension cable which you can then hang out your window or move to a better signal reception area,

i use a linksys usb adaptor for my surfing and it picks up many more packets than my orinoco,

unfortunately it is not supported by kismet,

i am going to buy one of these netgear ma111 adaptors and try it with knoppix-std,

that would be perfect for cracking wep,

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...