Jump to content

NANO Only Registers as USB Device When Plugged In Directly - Not with Y Cable (MacOS)


Recommended Posts

Hi everyone,

DISCLAIMER: Running MacOSX and using this blog strategy (https://www.evilsocket.net/2016/09/15/WiFi-Pineapple-NANO-OS-X-and-BetterCap-setup/) to share internet with my pineapple

I just received my NANO today and I've been messing around with it. I had the hardest time trying to share internet with the pineapple, even on a Kali VM, because I realized that the NANO wasn't registering as a USB device on my macbook pro while connected with the Y cable. My output for 'lsusb' on my mac and in my VM were both completely empty of the NANO. But, when I plug in the NANO directly to my USB port without the Y cable, it suddenly becomes recognized. What could be the issue here? Once I ramp up the usage I would like to connect an external battery to my NANO as well... I don't want to plug it in directly to my laptop just for it to work.

Also, side note, the NANO is showing up under my 'ifconfig' output as en8 but without an IP address. I can see the MAC address, just not the IP. Why could this be?

Link to comment
Share on other sites

I should add that this means that I am unable to run the wp6.sh script while in my Kali VM. Once I get to the 3rd item where it is looking for the pineapple, I get stuck on a screen that says "Please Connect Your WiFi Pineapple"...

I would much rather run my NANO off of the default IP in Kali VM rather than change the IP to suit Mac's weird ICS rules.

Link to comment
Share on other sites

The issue to has to lie somewhere between the nano and your chair. What else have you tried?

Could it be that since half of the cord isn’t plug in as a usb?

If you plug both ends into your computer at the same time, does it register differently?

I believe that one male end is thinner than the other. If so, could that mean that the thinner one is missing it’s data wires leaving only the ability to charge?

Have you tried swapping which male end goes where

Have you tried connecting the nano via a single usb extender cable

Keep us updated,

Goos luck

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...