Jump to content

Firefox device config not downloading?


Recommended Posts

  • Added a device
  • Selected the device
  • Pressed "Setup"
  • On the "Setup" dialog pressed "download"

Then ... nothing.

No browser download dialog, no system or error message, nothing.
The c2 system carries on working so it hasn't crashed.

I tried waiting a while in case it was some slow key generation but no joy. I tried generating a config file for a Pineapple, Turtle and Squirrel. Same happened (or didn't happen!)

I had a look in the logs and I can see MANY entries like,

"2018-10-02 15:13:35 Device 'Nano Test' had setup file downloaded by 192.168.20.101:38243"

which suggests c2 thinks it has done something.

I have c2_community-linux-64 running (as root) on a Debian 9 VM although the same happened using c2_community-windows-64.exe on Win10. I have used Firefox and Edge to connect to the c2 server (I did not want to install more browsers) as well as Firefox ESR on Linux.

I am not getting any AV or browser notifications stating that something is being prevented. The Linux / Firefox test was using Kali and that is not exactly known for being restrictive!

If others are getting their config files can anyone suggest what may be blocking this? (or something obvious I may have missed!)

Edited by aethernaut
Link to post
Share on other sites

Hi aethernaut,

Thanks for letting us know. We just fixed a bug affecting Firefox/Edge that prevents the generation of the config file inside the browser before download. Until we release this fix (very soon), I recommend using Chrome. Apologies for any inconvenience.

Link to post
Share on other sites

@Foxtrot

Many thanks for the quick reply.

I am surprised it was a bug because EVERYTHING ELSE I have touched today has gone horribly, horribly wrong... ?

Looking forward to the update.

By the way, in the live steam Seb mentioned running c2 on a Raspberry Pi. Is an ARM version in the pipeline?

Link to post
Share on other sites
  • Foxtrot changed the title to Firefox device config not downloading?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...