Jump to content

Installing languages with new firmware


Skiddie
 Share

Recommended Posts

I have yet managed to install the https://github.com/hak5/bashbunny-payloads/tree/master/payloads/library/general/DuckyInstall "tools" repo that includes the support for many keyboard languages using the traditional method that worked before firmware 1.1xx. It only gives me a weird combination of flashing lights, no logs or tools.

So if u wanna install those manually, this is how.

Download and "zip"/"rar" into https://github.com/hak5/bashbunny-payloads/blob/master/payloads/library/general/DuckyInstall/DuckToolkit-1.0.1.tar.gz

Go to Ducktoolkit -> Languages 

copy all the *.json file into the languages folder on the bashbunny while in arm mode (Switch closest to the USB Header)

Enjoy!

 

Link to comment
Share on other sites

I'm having a similar problem to Skiddie. I received my BB a few days ago, and it was running ver 1.0. I had a requirement to keep and RDP session alive, and the infinateControl payload worked great (i.e.presses CTRL every 10 seconds).

I upgraded to ver 1.1 and this no longer works. I think it may be something to do with the language. The languages folder is empty, and I've been trying to get hold of the gb.json file. I've downloaded the ducktoolkit from the link above, but as far as I can see there is no language folder within the tarball.

Any suggestions?

Link to comment
Share on other sites

Ignore my last message. Found the language .json files in the file. Unfortunately I've dropped them into the languages folder but the infinatecontrol payload still isn't working. It's such a simple script, I can't see why (it worked under ver 1.0 of the firmware)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...