Jump to content

Problems resetting LAN Turtle


Recommended Posts

I am following these steps from the wiki:

Factory Reset / "Unbricking"


In the extreme case that a LAN Turtle has become permenantly inaccessible or inoperative, there is a quick method for recovery using a special web interface.


  1. Download the latest factory image from https://downloads.lanturtle.com/turtle-2-factory.bin
  2. Carefully open the LAN Turtle case by removing the two screws underneath the sticker on the bottom
  3. While holding the button on the bottom of the LAN Turtle, plug the device into a computer
  4. After 3 seconds let go of the button and wait an additional 30 seconds to receive an IP address from the LAN Turtle
  5. If you do not receive an IP address in the 192.168.x range from the LAN Turtle within a minute, statically assign the LAN Turtle's interface to (netmask
  6. Browse to the LAN Turtle firmware recovery web interface at
  7. Follow the on screen prompts to upload and flash the factory image downloaded in step 1
  8. When the flash is complete the LAN Turtle will reboot and will be accessible again from with the default username root and password sh3llz

I do not get an IP in the 192.168.x.x range any time I hold down the button.  When I hold down the button on my Kali linux box it comes up as with a gateway of

If I manually set the adapter IP in Kali to I am not able to get to a website using my web browser.  I have tried this on a Linux Mint laptop, Kali linux laptop and Mac computer with all the same results.

I have tried holding the button for 1 second and for 30 seconds and places in between with the same results.

Do you think my LAN Turtle is defective?

Link to comment
Share on other sites

I was able to get my LAN Turtle working so I want to share what I did.

I had to manually set the IP address as explained in the instructions to for my wired connection.  I set a gateway of

I then added a route for the network with a gateway of  Once the route was added I was able to go to a browser and navigate to  The upload and restore of the firmware went perfect.

BOOM!  I am back in the game!

Link to comment
Share on other sites

  • 3 weeks later...

Could you by chance outline the exact steps you took?

I am having trouble with mine as well, however it seems as though it isn't working. I can't connect to it at all, even after adding a route. Unless I'm adding it incorrectly?


Would it be possible for you to take pictures of the steps you took as well, so that I will be sure to get it correct?

Link to comment
Share on other sites

I am using Linux Mint

I edited the properties of my wired connection which was the LAN Turtle, in my case it was Wired Connection 2

Under that I have an IPV4 tab and at the bottom is a Routes button.

I went into Routes and added a route for the network, subnet mask with a gateway of (which is the ip I statically assigned to that Wired Connection 2)

That is all.

Link to comment
Share on other sites

  • 2 years later...

Old thread but dusted off my turtle the other day and encountered the same issues. What I found was that I had to plug the device in first so it is detected then set the static IP as per @CrashOveride first. Next unplug the turtle, hold the reset button for 5 seconds while plugging back in and the static IP configured is assigned to the turtle and you can then update the firmware, remove the static settings and reconnect.

Only remaining bit to figure out for me is getting internet to the management interface so i can update etc. Currently I can browse internet via the turtle lan cable but I cant get the turtle itself to use this connection. any tips, or screenshots of routing config appreciated.

Screenshot from 2019-07-05 09-58-40.png

Link to comment
Share on other sites

  • 1 year later...


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...