Jump to content

Firmware upgrade during initial setup not working


Recommended Posts

I have an issue with the initial setup of my TETRA:

The connection via USB ETH works fine and I also can start the setup. But on the second step, where I'm asked to select a new firmware file to upgrade, I can select whatever firmware file I want (or even none) and it always brings me to the next page, that tells me, that the upgrade file was verified successfully and I should wait for the setup to finish. However, after about 5 seconds I'm redirected back to the file-selection page with the URL "".

I already tried different browsers (IE, Firefox) and systems (Windows, Kali) but it's the same with all of them.

Any idea, what I'm doing wrong? Or is there a way to skip the upgrade initially and do it later?

Link to comment
Share on other sites

I may be wrong but what you describe sounds like a mixture of initial setup and firmware recovery.

Initial setup to my knowledge (unless its changed) first confirms setup via wifi or not (quick or long press of reset button) then wants you to enter root password and SSID of management wifi details then follows on to the pineapple GUI.

Where as firmware recovery requires startup of the pineapple while holding the reset button and requires different connection to - then allows you to select and flash a factory firmware file.

Upgrading firmware via the GUI doesn't allow selecting of a file to upgrade so im assuming your doing a firmware recovery? more details can be found here https://www.wifipineapple.com/pages/faq

During the flash the new firmware is installed and the network is reset back to the normal pineapple - you shouldn't normally see the firmware recovery page while on that IP.

hope this helps, if not please provide some more description to what you are doing as it might help a bit more.

Edited by Just_a_User
Link to comment
Share on other sites

Wow, the problem was solved pretty easily now. I was stupid and accidentally tried to install NANO updates all the time and didn't double-check. :-)

However, it looks like my Pineapple started into recovery mode automatically. But after the upgrade (with the now correct firmware), I came to the initial setup GUI.

Thanks a lot for your help and quick response.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...