Jump to content

couple questions


owen
 Share

Recommended Posts

my issue could be due to lack of understanding though i have spent a good amount of time reading the help pages.  Im trying to figure out 2 things.  How to share internet with the device so it can download modules and check for upgrades (FYI im at 1.0.6 which is most recent) and find out why Wifi Client Mode doesnt list any interfaces.

When I go to networking>WIFI Client Mode my Interface list is empty and Scanning always results in nothing found. How can i use this feature to connect it to my home wifi?  it mentions in the documentation that this and pine ap cannot be on at the same time so pine ap is turned OFF.

In an attempt to get internet access without wifi client mode I plugged an ethernet from the wan port to the lan port on my router, which put the pineapple into bridged mode. When i connect to it while its in this mode it of course sends out the subnet and ip details of the bridged network.  So I manually change my settings to get onto the 172.16.42.1 subnet and I am able to access the pineapple.  however the device itself does not have internet (cant check pineapple.com for messages, modules or upgrades).  I tried updating the Route in Network settings but that doesnt seem to do anything. 

I have also tried an android phone plugged into the usb while running the pineapple app but it hangs on "Waiting for connection".

Link to comment
Share on other sites

another post revealed that the GL-AR150 only has one radio and this is why wifi client mode doesnt show another interface

but regardless there should be a way to get internet on it via the wan port

Link to comment
Share on other sites

The firmware is designed specifically for the Pineapple Nano.

Sure you could deconstruct it and change bits around, but it's not made for different hardware, so it'd be a chore to say the least.

Link to comment
Share on other sites

the drivers seem to be loaded as it does bridge the connection.  what scripts are you talking about?  

I would have thought that i would do this (however this doesnt seem to work as the destination address never changes 

route.png

Link to comment
Share on other sites

ifconfig:

br-lan    Link encap:Ethernet  HWaddr E4:95:6E:40:80:50
          inet addr:172.16.42.1  Bcast:172.16.42.255  Mask:255.255.255.0
          inet6 addr: fe80::e695:6eff:fe40:8050/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15923 errors:0 dropped:0 overruns:0 frame:0
          TX packets:98569 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1434165 (1.3 MiB)  TX bytes:7157832 (6.8 MiB)

eth0      Link encap:Ethernet  HWaddr E4:95:6E:40:80:50
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:7747 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3247 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:866190 (845.8 KiB)  TX bytes:785891 (767.4 KiB)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:105631 errors:0 dropped:0 overruns:0 frame:0
          TX packets:105631 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7987545 (7.6 MiB)  TX bytes:7987545 (7.6 MiB)

wlan0     Link encap:Ethernet  HWaddr E4:95:6E:40:80:50
          inet6 addr: fe80::e695:6eff:fe40:8050/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4457 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:452740 (442.1 KiB)

wlan0-1   Link encap:Ethernet  HWaddr E6:95:6E:40:80:50
          inet6 addr: fe80::e495:6eff:fe40:8050/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4827 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8014 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:517792 (505.6 KiB)  TX bytes:1812334 (1.7 MiB)

 

lsusb



Bus 001 Device 004: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

Link to comment
Share on other sites

when i look on my router it shows the ethernet being used at its ip address

when its connected to the wan port of the ar150 and i connect to the wifi, i get an ip of the routers subnet

maybe its just passing the ip through

cuz like i said, while in this mode the ar150 stays with the 

172.16.42.1

address.

 

another thing i dont understand is why cant wlan0 and wlan0-1 work for doing the wifi client mode

Edited by owen
Link to comment
Share on other sites

21 hours ago, barry99705 said:

Looks like your wired connection doesn't have an ip address.

eth0 needs to be enabled first, before you update the firmware, as it default configuration is disabled.  you will also find
most of the infusions/modules will not work on the ar150 without serious modification to the firmware's binaries.
The nano is a purpose built board to which the pineapple software has been re wriitten for.

regards
kerravon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...