Jump to content

ICS on a Mac


Recommended Posts


I am having some fun with my brand new Pineapple NANO but there's one thing I cannot understand.

I create an Open AP SSID for some testing and enable Internet Connection Sharing on my computer (currently working on a Mac), sometimes everything works fine and sometimes it does not.

If I connect with my phone to that SSID, I see that sometimes (and I have no control on that) it gets a 192.168.1.x IP address (and everything works) and sometimes it gets a 172.16.42.x IP address (and nothing works).

What regulates this IP assignation?

Thanks for your help,


Link to comment
Share on other sites

Automatic IP designation is usually done via Dynamic Host Configuration Protocol (DHCP), for computers in general. There might be several things that could be going wrong. One thing I can think of is that you have 2 dhcp servers on you network are trying to dish out info and they are competing. Another possibility is there just happens to be another open wifi network near by that you are sometimes connecting to instead of your pineapple.

Link to comment
Share on other sites

if you have access to a computer with nmap:

$ sudo nmap -sU -n --script=dhcp-discover -p 67
$ sudo nmap -sU -n --script=dhcp-discover -p 67
I think this will display info about any dhcp servers on the 2 networks and

Its possible that these 2 network ranges overlap each other

Edit: changed to new ip ranges

Edited by fugu
Link to comment
Share on other sites

Thanks but I think it has something to do with this topic:

- https://forums.hak5.org/index.php?/topic/30516-wifi-pineapple-mark-v-on-osx/

- https://forums.hak5.org/index.php?/topic/28552-wifi-pineapple-mark-iv-no-internet-connection/

And it's caused by something I am not understanding in Mac OS Internet Connection Sharing management.

I'll try on a Linux machine using wp6.sh script.

Link to comment
Share on other sites


that is the setup for a tetra on mac but it works with the nano also.

Make sure you have the realtek driver installed and add the last three lines through terminal

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberStart

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberEnd

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkMask

I then had to set the DHCP manually under the AX88x72A in the network preferences to and it works great.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...