Jump to content

recon kills client mode


lucserre
 Share

Recommended Posts

When wlan1 is on client mode, and I go to the recon page and do a client and AP scan, it kicks wlan1 off client mode, and when I go back to networking page, I see client mode has wlan1mon there. I can login to ssh and "airmon-ng stop wlan1mon" to fix the wlan1mon being left on, but I'm still forced to manually reconnect client mode.

Is this the intended behavior or is something being buggy?

Thanks,

-Luc

Link to comment
Share on other sites

I have this problem with a 3rd adapter, when it's connected to a client AP and run recon with both chosen it seems to freeze the nano interface entirely ... most of the time. The few exceptions were when client mode was enabled but not connected. As soon as the AP is connected to, thats when things go crazy. Tried on a battery and connected to computer to rule out battery not giving it enough.

Recon mode / PineAP requires both wlan0 and wlan1. You cannot run clientmode on those interfaces if you want to make use of such features. For that you will require a third radio.

Best Regards,

Sebkinne

Edited by purrball
Link to comment
Share on other sites

##Yeah. I mean of course it can. Seems like that is simple enough.

##It's fine for a 15 second scan. Usually. But if the setting is on aggressive than it usually hangs.

##I've used WiFi analyzer and it's very pretty to watch the broadcast.

##I pick up beacons too on the host computer when running recon. Not as much of an issue there.

##But yeah. I think if we want recon to run well with beacon or ssid broadcast. We probably at least want a gui setting.

##I just don't know where the file is. Or if I can edit it. Pineapple is one of my learning experiences on arm and 2.4ghz. I have the concept down in theory but lack ##the practice at this point.

-------------Redacted----------------

Simply filter the mac address of wlan1, wlan2, wlan0-1, wlan0 using the built in filter.

However this should be handled by the pineapple, hooked into networking tab when the mac addresses change. Essentially adding wlan0 should cover it but you wanna go for wlan2 too because you could broadcast ssids there. Otherwise if this isn't a system feature there is always that off chance you could jam up your pineapple forgetting to update the macs.

For people using client mode, there is a chance if your wlan0-1 connection is weak if your antenna/ location situation is not on point. Also same goes for the features of the pineapple that require internet and wlan2. The host disconnects from pineapple. It looks like it's jamming up but after you give a moment for the connection to establish everything works fine or move to better signal. 2dbi antennas folks are not gonna penetrate through a whole bunch of wall. Neither is a nubby wifi for wlan2. You got to consider an amplifier is gonna help a whole lot. Also a 5-7dbi antenna set.

Currently running for 2 days 1 hour. I've been on 10 minute continuous for 50 minutes. Broadcasting 500 ssids. With beacon mode enabled.

NO CRASH

Which is actually because recon stops broadcasting ssids when deny is set. Weird.

Edited by Kapu Lanai
Link to comment
Share on other sites

Should be helpful if something like this were to be added.

My main concern now is not being able to get any associations or use PineAP when I'm connected with WiFi Client mode. PineAP just does nothing. It's "running," but I disabled broadcasting SSID's to help, but it picks up nothing new. As soon as I disconnect wlan2 from the hotspot, it seems to start working again, and by that, I mean it will start adding AP's to the pool... no clients connect still, but it does something at least. Has anybody else run into this?

​-CPU usage stays low, too, and I checked to make sure nothing was causing it to spike.

​​-PineAP log states that the only probe requests are for the Management AP

​-dmesg output seems normal

​-Filters are both in deny mode

Edited by purrball
Link to comment
Share on other sites

Not all batteries are made equally. I have a few, pineapple juice one of them. I prefer the pineapple juice because I get that consistent draw from the one connection.

My other requires USB y. But as that battery depletes it becomes inconsistent. I think one channel gets more of the juice towards the end which is a cause of instability. At the end of the day that battery is an emergency phone charger stretching to fulfill it's purpose powering the pineapple. It's also straight from China and I don't even know if it's to spec.

Really 2Amps on a single USB should be enough. Go for larger milliamphour. It's about the mahs. The amps. USB y might be an issue for those dual ported batts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...