Jump to content

Kail Linux 2.0 : Need help with subterfuge


Caps
 Share

Recommended Posts

Hello,

I want to use subterfuge but I am getting an error , please help me:

Traceback (most recent call last):
File "/bin/subterfuge", line 7, in <module>
from update import updatecheck
File "/usr/share/subterfuge/update.py", line 24, in <module>
for settings in setup.objects.all():
File "/usr/lib/python2.7/dist-packages/django/db/models/query.py", line 141, in __iter__
self._fetch_all()
File "/usr/lib/python2.7/dist-packages/django/db/models/query.py", line 966, in _fetch_all
self._result_cache = list(self.iterator())
File "/usr/lib/python2.7/dist-packages/django/db/models/query.py", line 265, in iterator
for row in compiler.results_iter():
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 700, in results_iter
for rows in self.execute_sql(MULTI):
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 775, in execute_sql
sql, params = self.as_sql()
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 100, in as_sql
out_cols, s_params = self.get_columns(with_col_aliases)
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 246, in get_columns
col_aliases)
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 328, in get_default_columns
r = '%s.%s' % (qn(alias), qn2(column))
File "/usr/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 62, in __call__
r = self.connection.ops.quote_name(name)
File "/usr/lib/python2.7/dist-packages/django/db/backends/dummy/base.py", line 18, in complain
raise ImproperlyConfigured("settings.DATABASES is improperly configured. "
django.core.exceptions.ImproperlyConfigured: settings.DATABASES is improperly configured. Please supply the ENGINE value. Check settings documentation for more details.

I followd the instructions on the git site : https://github.com/Subterfuge-Framework/Subterfuge

Please send help , Caps....

Link to comment
Share on other sites

Caps,

I was able to get Subterfuge installed on Kali 2 (rolling-edition) with only a four commands.

My suspicion is that you are trying to do something more ;D

Here's what I did to get the install going.

In Brief:

root@localhost:~# git clone https://github.com/Subterfuge-Framework/Subterfuge.git
root@localhost:~# cd Subterfuge/
root@localhost:~/Subterfuge# python setup.py
root@localhost:~/Subterfuge# subterfuge

The Long Version:

root@localhost:~# git clone https://github.com/Subterfuge-Framework/Subterfuge.git
Cloning into 'Subterfuge'...
remote: Counting objects: 419, done.
remote: Compressing objects: 100% (25/25), done.
remote: Total 419 (delta 6), reused 0 (delta 0), pack-reused 392
Receiving objects: 100% (419/419), 4.43 MiB | 7.41 MiB/s, done.
Resolving deltas: 100% (149/149), done.
Checking connectivity... done.
root@localhost:~# cd Subterfuge/
root@localhost:~/Subterfuge# python setup.py
[+] Beginning Subterfuge installation...
Get:1 http://archive.linux.duke.edu/kalilinux/kali kali-rolling InRelease [24.6 kB]
Get:2 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/main amd64 Packages [13.4 MB]
Get:3 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/non-free amd64 Packages [145 kB]
Get:4 http://archive.linux.duke.edu/kalilinux/kali kali-rolling/contrib amd64 Packages [93.0 kB]
....
## Boring installation stuff here.
....
Installing collected packages: django
Successfully installed django
Cleaning up...
[+] Subterfuge installation completed successfully!
root@localhost:~/Subterfuge# subterfuge

Subterfuge courtesy of r00t0v3rr1d3 & 0sm0s1z
Performing system checks...

System check identified some issues:

WARNINGS:
?: (1_6.W001) Some project unittests may not execute as expected.
    HINT: Django 1.6 introduced a new default test runner. It looks like this project was generated using Django 1.5 or earlier. You should ensure your tests are all running & behaving as expected. See https://docs.djangoproject.com/en/dev/releases/1.6/#new-test-runner for more information.

System check identified 1 issue (0 silenced).

You have unapplied migrations; your app may not work properly until they are applied.
Run 'python manage.py migrate' to apply them.

March 07, 2016 - 19:52:35
Django version 1.7, using settings 'subterfuge.settings'
Starting development server at http://127.0.0.1:80/
Quit the server with CONTROL-C.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...