Jump to content

Mounting 2TB HDDs in Zen Server


WULTKB90
 Share

Recommended Posts

I have been playing around with Zen server, it makes life easier when I want to try out a new OS or something on an OS, but the machine I run it in is also used as my backup/media machine. I have three, 2TB hard drives for storage in the machine and have not been able to find a way to mount them, I am not so familiar with linux based systems, so far as I know fstab by default can not suport 2TB at least I have not been able to set the hards drives up in it and Zen server does not find them either in the Zen Center or the macine UI. Does any one know how I can mount the HDDs in the Zen Server?

Link to comment
Share on other sites

so far as I know fstab by default can not suport 2TB

Well we're off to an amazing start then because this is utter bullshit. I've mounted far bigger RAID devices without any issue.

Start by doing this:

fdisk -l /dev/sd?

It lists the partition table of every harddisk device on your system.

If your drive is not amongst them it means the OS didn't detect it.

If however it is in there, you now have its device name (/dev/sd[something]) and its partitions which is what you need to provide in your fstab if you want to mount said partition(s).

Link to comment
Share on other sites

I meant to type fdisk instead of fstab as the 2TB HDDs are all GPT and aparently fdisk has issues with it as I said I am new to linux and this is just what I found while trying to find a solution online.

When I run the list command it brings up the four HDDs I have installed and their names sda, sda1, sdb, sdc the last three all come up as EFI GPT partitions at 2000.3 GB.

I need to know how I add these to the server so they are usable as they are with no formatting as moving the data around it a pain, that is where I am stuck.

Sorry about the delay.

Link to comment
Share on other sites

Thanks, I was able to get the GUID information for each drive, but I do need to make sure as I don't have a back up for those HDDs, if I add the GUID and other information to fstab would they then be accesable to the operating systems I have running in Zenserver and what program do I need to use to edit fstab with zenserver?

Link to comment
Share on other sites

fstab is a plain text file interpreted by mount. Find something that edits text which you enjoy working with and you should be sorted.

If you mount by guid then you would name the drive using that in /etc/fstab. Not sure what there is to make sure about - either it works or it doesn't. In the one case you're done, in the other there's some more work to do, whatever that may be. Either case nothing's going to break because of it. You could include the ro option on the appropriate line of the fstab file to request the drive be mounted read-only until you know things are good, but I'd consider that overkill.

Link to comment
Share on other sites

Fair enough, so far as I can see that would be the last step but I keep getting an error each time I try to use the mount command I added to fstab:

dev/sdb / ntfs ro 0 0

Then I ran:

Mount dev/sdb

and I get the error wrong fs type, bad option, bad superblock on dev/sdb missing codepage or other error.

I first tried adding

LABLE=<then the lable> / ntfs ro 0 0

But when I tried mounting it by the lable it just told me that it didn't exist in fstab.

I know I have made some rookie mistake but I am not sure where.

Link to comment
Share on other sites

Things might have changed over time, but I thought you couldn't use the regular mount command to mount an NTFS drive. Instead you were supposed to do something with FUSE, which, I might add, requires some kernel support.

If you want to mount by id, do 'ls -l /dev/disk/by-uuid' and discover which ID is the one for the drive you want. Refer to it in fstab by using "UUID=<uuid>" for the first column.

If you want to mount by label, do '/dev/disk/by-label' and discover which label is the one for the drive you want. Refer to it in fstab by using "LABEL=<label>" for the first column. Note that you used the incorrect spelling.

When you mention a label or uuid, mount will look in that appropriate /dev/disk/by-... directory for it. Obviously if it can't find it it will get angry with you.

Link to comment
Share on other sites

Ahh fair enough, I will look into installing fuse and how to change the kernal hopefully it will work after that. if push comes to shove I could always move all the data and reformat the drives as ext4 I can still use them on windows machines.

Thanks for all your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...