Jump to content

Wifi attack: adapter disconnects during attack (below 5min)


Botmaster
 Share

Recommended Posts

I use alpha nha adapter. I added 9dbl antenna. I'm using it now for wpa attack.

First problem was adapter repeated disconnecting. It fixed after I changed from usb3 to 2.

Second problem is when I use fern or reaver to attack wpa. After just 1 min adapter disconnects. I could increase it to 5min by manually switch adapter to monitoring mode before running fern, but still below 5min it disconnects.

Questions :

-is it possibly for not enough electricity through usb for adapter with 9dbl antenna? Then whats your suggestion

-is it fern and reaver bug? ( i dont think so)

Is it kali driver issues with atheros?

Thank you

Link to comment
Share on other sites

1. Likely. Fix is to use a powered USB hub.

2. Need more info to determine.

3. Need more info to determine.

Regarding 2 and 3, imagine the following:

You call up the garage and tell them you hear a 'strange noise'. You then ask if it's the brakes, the engine or the radio.

Are you smiling? You should be. But you're also currently doing the exact same thing with your machine.

If it's a driver problem, check the system logs. If you don't know how to do this, stop using Kali.

If it's a program bug, see if it keeps any logs anywhere and try to figure out, based on what they say, what might be the problem.

Link to comment
Share on other sites

Dude, using kali or this website is not only from very professional users. Anyone beginner also got questions, it would be helpful if u give suggestion instead of don't use kali stuff!

Go find log for bug problem, go find log about driver issue,... Analyzing bugs needs some acknowledge which i dont have it enough, thats why i do ask question here so people who know more than me can help. Many people might have same hardware and software experiences and can help. It's not like always u look at log and u can figure out the problem easily.

My host is win 8.1 64bit. Adapter works fine when I use win7 compatible option driver.

In kali, it works fine before I start the attack. Only during attack, adapter gets disconnected. Kali is 64bit running in vmware 64bit.

Anyone got similar experience?

Thank you

Link to comment
Share on other sites

Right. Here's the problem with your original question, and why you're wrong with acting how you're acting now:

You're only just now saying you're running this from a VM. Never mentioned that in the original question. Didn't think that might be relevant?

You've tested the adapter and it works just fine in Windows. Never mentioned that either.

You've actually even tested the adapter from within the VM without doing the attack and that also works just fine, which, again, you never bothered to mention.

Do you REALLY think none of this information is even remotely relevant to people who're interested in helping you get going?

The fact of the matter is that Kali is to be assumed an 'advanced' Linux distro. If you don't know what you're doing, you're better off using something more consumer-grade. Not because it's easier or less capable - it's not, by any means. It's because it helps you more in discovering what might be wrong and how to fix things. Linux is Linux is Linux. The distro's only differ in what they provide from the clean install, and how they set up system management. In Kali, the concept is simple: you're root. Instant god-mode on your system because we understand you know what you're doing and wouldn't want the system's typical protections to get in the way of that. It you were to try your hand with Ubuntu, Redhat or some other common distro you'll find that you need to say "yes" to the "are you sure" question a lot more often, and need to provide the root password often when trying to hack.

Now, Kali does in fact do things with its drivers to make them more hacker-friendly. Things that don't always work out as well as you would expect. Now, if the card stays on when used normally (i.e. during a big, fast download that takes more than 5 minutes) there's nothing wrong with the power being supplied to the adapter. And while I wouldn't put a bug past either fern or reaver, you'd get some sort of error log or core file or, well, something that says the thing kicked the bucket. My bet would be that the driver is kicking up a shit storm. So check the system logs. You get that on the screen with the 'dmesg' command. Try posting the last minute or 2 of logs halfway during which the adapter has gone down. It should tell you a lot of how the kernel is seeing things. And yes, try a more consumer-friendly version of Linux with a more standard version of the kernel. See if you get the same problem, or if something else happens. I wouldn't be surprised if the errors you ended up with, assuming you still get them, are far less cryptic.

Edited by Cooper
Link to comment
Share on other sites

well. I have experienced this befor, with a kali rasp pi... ill give cooper some props as it seems to be a kali problem... software/driver/service issue... this device had no problem in linux mint... try a usb powered hub if you have one... i think I tried older versions of aircrack... I tried everything, so once I got a stable machine I just made a backup...

tail -f /var/log/kern.log

Monitor This console, start your attack...

Edited by i8igmac
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...