Jump to content

Cannot set password for Pineapple Mark V


Recommended Posts

Hello all,

I am borrowing a WiFi Pineapple Mark V from my professor to do a small hacking project. I assume someone else used this device before me, because when I started going through the steps for a first-time setup in the manual, I found that instead of seeing this start screen:


...I saw a different screen asking me to put in a username (default "root") and password. Instead of doing what probably would have been the easier option and asking my professor what the password was, I decided to reset the pineapple and start from the top.

At first, things seemed to be going as expected. The red, orange, and blue LEDs blinked on cue, I connected to the pineapple through a spare TP-LINK device I had laying around, and I was able to ping and later connect to after setting my main wireless connection to "share" with the TP-LINK and changing the TP-LINK's default IP to (I can ping that address too). However, once I got to this screen:


...things stopped working as expected. I have tried several times with three different web browsers to set a password on this screen, and every time it loads a white screen with the message "The CGI process did not produce any response" on it. I have tried powering off and rebooting the device, and reset it a second time to make sure.

Can someone tell me where I've gone wrong?

Link to comment
Share on other sites

I suggest you either follow the directions to make a wired connection to your PC/laptop, or connect wirelessly to the default pineapple AP.

I don't know what this "spare TP-LINK device" is.

And I assume you checked the two accept check-boxes,

Edited by fringes
Link to comment
Share on other sites

I don't know what could be happening. I've never set "my main wireless connection to "share" with the TP-LINK and changing the TP-LINK's default IP to" For a wireless connection, I just connect to the pineapple AP and let the pineapple provide the address.

I suggest you take the wireless connection out of the mix for now and just start with a wired connection, following the setup instructions for that interface (which it sounds like you applied to the wireless connection). Once we know that's correct and working, we can address your original issue if it still exists.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...