Jump to content

Trouble Installing Kali linux, Key Exchange Failure


Kalikid
 Share

Recommended Posts

So I've been Having some trouble installing the newest version of kali linux:

kali-linux-1.0.9a-i386

or the amd64 version

My host OS is ubuntu and im trying to install it on a secondary partition[to dual boot]

But every time I get to network configuration, It gives me an error message that says

Key exchange failure check the wpa/wpa2 parameters you provided.

Im not sure why im getting this error the password i provided is correct, and when i tried installing it in a VM
it had no problem with network configuration.

Ive had no problems with this before, but it doesn’t seem to make any since to me. I could be standing a foot from the router and it will still give me the same error.

whats going on here??



Link to comment
Share on other sites

How are you connecting? Manually with wpa supplicant or with the built in wifi gui app?

Link to comment
Share on other sites

How are you connecting? Manually with wpa supplicant or with the built in wifi gui?

To be completely honest and show my ignorance, I dont know what wpa supplicant is, Im attempting to connect during the install process,(which is required to complete the installation)

regular install not graphical

so i guess its a gui, but not much of one. very basic

Link to comment
Share on other sites

I would say consult the documentation for installation help, but dual booting, I have backtrack installed on my laptop, and installed uBuntu afterwards for my wife to use linux, and it was able to do the install for me. You should be able to skip any network needed install options unless you are strictly doing an internet based install only.

http://docs.kali.org/

http://askubuntu.com/questions/492016/kali-linux-to-be-installed-as-a-boot-option

Link to comment
Share on other sites

You're installing in a VM using wireless networking.

Did you remove the wifi adapter prior to starting the VM and insert it later, or was it inserted from the start?

You see, if it was inserted from the start, the HOST will have initialized the adapter and is now using it to provide networking services to the system. Your HOST should provide the VM a virtual, *physical* network adapter whose traffic gets either bridged or NATted onto the real network (bridged most likely). Because the HOST controls the adapter, the VM isn't allowed to modify its settings. So, look at the VM software and how it exposes the HOST's network to the VM to find a solution.

The alternate solution is to remove the network adapter from the HOST before starting the VM. When the VM boots up, it takes control (to some extent) of the USB bus. When, during the install process you reach the point where the network comes into play, re-insert the adapter and it will get detected by the VM (and not the HOST). Now that this has happened, the VM has full control of that device and can configure it in any way it wants.

This is a common mistake people make when dealing with wireless networking from a VM. If you want the VM to play with wifi, then it must be the one to detect the device.

Link to comment
Share on other sites

You're installing in a VM using wireless networking.

Did you remove the wifi adapter prior to starting the VM and insert it later, or was it inserted from the start?

You see, if it was inserted from the start, the HOST will have initialized the adapter and is now using it to provide networking services to the system. Your HOST should provide the VM a virtual, *physical* network adapter whose traffic gets either bridged or NATted onto the real network (bridged most likely). Because the HOST controls the adapter, the VM isn't allowed to modify its settings. So, look at the VM software and how it exposes the HOST's network to the VM to find a solution.

The alternate solution is to remove the network adapter from the HOST before starting the VM. When the VM boots up, it takes control (to some extent) of the USB bus. When, during the install process you reach the point where the network comes into play, re-insert the adapter and it will get detected by the VM (and not the HOST). Now that this has happened, the VM has full control of that device and can configure it in any way it wants.

This is a common mistake people make when dealing with wireless networking from a VM. If you want the VM to play with wifi, then it must be the one to detect the device.

Im not trying to install it in a vm.

Link to comment
Share on other sites

Im not trying to install it in a vm.

That said, running from the VM, networking might have worked if it was being passed from the host directly to the VM. Your best bet, boot off a live disc, see if networking works with your hardware, wired and wireless. if not, that may be the culprit, and you may need a USB wifi adapter to work around the issues you're having.
Link to comment
Share on other sites

Im trying to install kali on an empty partition on my hard drive.
This problem doesnt make any since to me. I just tried it with a different AP,
that im literally 5 feet from, correct password. same issue. failed to exchange key with AP.

im thinking maybe there was a problem writing the kali iso to the usb.
I've never had this problem before and there doesnt seem to be an easy solution.
Im going to re-download the iso and re-write the image to the usb and see if i have the same problem.

Link to comment
Share on other sites

You got me on the wrong foot with the "host OS is ubuntu" bit in your message.

I think digip was bang on the money with his wpa_supplicant comment. The wpa_supplicant program deals with the encryption and authentication of a wireless connection. I don't know how Kali does it specifically, but if you can access a command prompt before it reaches the point where it asks about networking, see if there's a "/etc/wpa_supplicant/wpa_supplicant.conf" file on the system. Here's an example of what should be in that file for your setup.

Here's the man page for wpa_supplicant. You're probably going to have to (re)start it (if it was already running).

Once it's running and using your modified config file, you should only need to bring up the interface using dhcpcd to get the connection going.

Edited by Cooper
Link to comment
Share on other sites

You got me on the wrong foot with the "host OS is ubuntu" bit in your message.

I think digip was bang on the money with his wpa_supplicant comment. The wpa_supplicant program deals with the encryption and authentication of a wireless connection. I don't know how Kali does it specifically, but if you can access a command prompt before it reaches the point where it asks about networking, see if there's a "/etc/wpa_supplicant/wpa_supplicant.conf" file on the system. Here's an example of what should be in that file for your setup.

Here's the man page for wpa_supplicant. You're probably going to have to (re)start it (if it was already running).

Once it's running and using your modified config file, you should only need to bring up the interface using dhcpcd to get the connection going.

Yeah I probably could have used better terminology when describing the situation, but at the time I couldnt think of a better way to explain.

sorry for the confusion.

and as for an update on the issue.

i re-downloaded the current iso from kali.org, the direct download not the torrent, wrote it to usb.

and im still having the same problem so, since im not to comfortable editing config files, as im not a programmer or a computer professional

im downloading an older version of the OS , 1.0.7 to be specific, and we'll see if it has the same problem,

I dont think i will, as prior to 1.0.9 I never had this issue, and if it works. ill just upgrade from there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...