Jump to content

Flash over SERIAL possible with MK V?


python2004
 Share

Recommended Posts

as some of you might have seen I am struggling with boot problems after the update to 2.0.4

I can do what I want - I cannot manage to get any connection.

So my question is whether there is some sort of tutorial for setting up a connection to the MK V over serial? I didn't find any - only for the MK IV!

Would it be possible to connect over serial, while it is not possible to connect via ethernet? May be in this way I could avoid a replacement.

In a shop nearby I discovered a "USB to serial"-cable for a raspberry Pi, but that should be suitable for the pineapple, too?!

Link to comment
Share on other sites

Yes I tried really everything! Nothing worked!

But today I tried a tipp of another forum's user who said to wait a few hours after flashing before trying to reboot.

I left my MK V alone for 48 hours after last flash-attempt and YIPPPIEEEE!!! Today it booted quite normally and I also could install an upgrade!

I tried the update to 2.0.3 (actually I am still a little bit afraid to try 2.0.4 again), but not using the web interface but using WinSCP for file transfer and Putty for sysupgrade command.

I still don't understand what was the cause for this problem. May be there was something bad in the 2.0.4 upgrade that only disappears after some hours without power supply???!?! Is that possible?

Link to comment
Share on other sites

maybe is keeping a bad cache, and is cleared when say capacitors are depleted from not being plugged in? i remember similar issues with a different router i had. and also i believe the original nintendo wii did this too lol all just had to be unplugged for a day or so. i cant say its deffinately a bad cache, but its something that the pineapple was keeping in memory and the trickle from a capacitor was keeping it alive more than likely. more than likely something to do with the kernel or libs? just my opinion :)

also, maybe it would be worth putting your steps up on the wiki and list it under troubleshooting for future users who may have similar issues

Edited by datahead
Link to comment
Share on other sites

@python2004 im using 2.0.4 runs fine for me just gotta be care with some of the infusions i've had a couple that caused a boot loop in the past not sure if they have been fixed since i made my threads or comments about that. I believe it was the Pineapplestatus that was giving me a boot loop in the past

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...