Jump to content

SDR# "no compatible devices found"


Recommended Posts

Hello, I just bought a SDR with the same chipset as the hak5 shop one and I have followed all the driver installation instructions on this site http://rtlsdr.org/softwarewindows however when I click "start" in SDR# I get the error "no compatible devices found".

I have looked in device manager and the SDR is using the drivers from zadig.

Not quite sure what is going on, any help is much appreciated.

Link to comment
Share on other sites

Well that guide says you should install the driver provided with the dongle, and then use that zigthing to replace it.

Link to comment
Share on other sites

  • 3 months later...

Found out more issues that may help>

-if you change the the USB port you might [will] have to re-install zagig 210

-Might not work with USB3

-Long USB cords will kill it. took the 2m extension cable off plug it back in and off it went.

Will test out an active 5m cord see how that goes.

Link to comment
Share on other sites

  • 1 month later...

Well, I tried installing on a machine with USB 2.0 ports and no go.

Still no compatible devices found.

I've been trying to install this for a couple months off and on and I just can't figure out what I'm doing wrong. I'm following the directions provided here http://rtlsdr.org/softwarewindows as best I can... I download the latest version of Zadig.. I've done this so many times, I don't believe I had to use 7zip and I'm not sure where or what the .7z file is. The directions don't tell you much about that. It just says extract from .7z ???? Anyway, somehow, I get the Zadig open and I click on list all devices and choose the bulk/in interface 0 but now it lists itself as RTL 2838 HIDIR or something like that and I install/reinstall the drivers many times. It then says make sure the USBID matches the VID/PID in the hardware table. and it doesn't but theres no direction from there in the directions anyway so that must not matter. Then I download the SDR-Install.zip and unzip it. Then I'm supposed to dbl-click on the install.Bat file but there is none so, I dbl-click on the install.Batch file.. (you can probably see whats going on here by now..) After a few tries, a large file script with everything I need is downloaded.. Once this is done I find this SDRsharp directory and then I download the Zadig driver again (for good measure). Now that the Win USB is installed, I am ready to run SDR#sharp with the RTL-SDR/USB input device. I run SDR sharp (the icon) because there is no SDRsharp.exe and I see the window of the installed SDR# player. I set to WFM, set freq to 88, set front end to RTLSDR/USB, the front end button goes from grey to black, I click on play..... "No compatible Devices Found" or "No SDR device istalled etc. etc. on and on.

So, that's my story complete with snark and sarcasm... My guess is that one of these steps is not correct. I've highlighted a number of places where mistakes could've been made. I've tried installing a friends RTL dongle, I've tried this on a different machine and no luck so, I'm pretty sure it's me. If you can stand reading through this please let me know what you think. Whwere does my demetia begin?

Thanks Chris

Link to comment
Share on other sites

  • 3 weeks later...

Hi everyone,

Installing in safe mode is how I got this to work. I re-installed the driver about ten times as well as running every application I could find in the SDR# list.

I also installed a number of random applications from other SDR products such as HDSDR and RTL_SDR.. Not sure which ones made any difference.

Anyway, now it works.

Thanks for all the helpful advice.

Chris

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...