Jump to content

Alfa Drivers Disc Rip Request


Enigma83
 Share

Recommended Posts

I bought the Alfa AWUS036NHA awhile back, and I've been having lots of fun messing around with the adapter and WiFi Pineapple since then. As we know, the adapter ships with a disc. So I ripped a copy in ISO format and uploaded it to my Dropbox. Awhile later I had trouble getting the adapter to work in Windows 8.1 alongside my built-in adapter, among other issues with the OS, so I rolled back to Windows 7, and I've been with it ever since. I couldn't get it to work in 8.1 no matter what I tried, and it still doesn't work now. 7 recognizes it without issues. So now I'm sticking with what I have for a long while.

But anyway, I tried Dling the file drom Dropbox, it came out corrupted after multiple tries, and some files inside the image were missing, setup would crash, etc. And the image was unusually much smaller than it should have been, even though I'm sure I ripped it correctly. I still have the disc but it got scratched as the result of a friend's dog chewing on the jewel case it was stored in. I know someone will say, "but you can get newer files off the Net", and that's true. But it contains older versions of the drivers for Linux as well as Mac (planning on installing Hackintosh soon in a small partition, just to mess around), and I would like to have copies of those for archival and testing purposes. I dont think copyright will be an issue, since it's just drivers, there is no real copyrighted content on the disc, and I doubt that either Alfa or the driver producers would seriously object.

So...........I'm wondering if someone with a pristine disc would be willing to rip an image and upload it to somewhere so I can fetch it. Alfa doesnt seem to have their own forum for me to post in, so I figured here would be a good place. I'd really appreciate this (and if it can't be done for whatever odd reason, please specify why).

Thanks in advance for any help!

Link to comment
Share on other sites

@ Mr. Protocol: I have already searched the Alfa website, they only have the most recent drivers, not the ones on the disc. Nor do they make the disc available for download as an ISO, etc. And they dont appear to have the drivers for Mac and Linux, which the disc does have. I checked this already. I'm basically asking for an ISO rip of the actual disc. I'm 100% positive that some of the files are different. And it also contains the drivers not just for Windows, Mac, and Linux, but for most of the Alfa products as well. If what you're saying had been an option, I wouldn't have bothered posting here.

Thanks in advance!

Edited by Enigma83
Link to comment
Share on other sites

Thanks for that. It seems to be the right disc.I'll be keeping a Dropboxed copy, as well as a local copy, and a burned disc. I've found that 8 performs better than 7 overall, especially for games, and I would really like to be able to use my legally licensed copy without issues. The drivers on the disc worked fine for 7 and still do, and they also worked for 8. But then Microsoft released 8.1 and it suddenly didnt work anymore. By that point I only had the drivers on Alfa, and they didnt work on 8.Without this device being operational I couldn't fool around with Wireshark or other networking utilities in 8, without a suitable device to use them with. I suspect that the disc may or may not solve the issue. Right now I'm maintaining a small 8.1 install alongside 7 and Mint, for testing purposes.

The real problem seems to be that I have a Lenovo laptop and it has an internal Broadcom adapter, which just sucks. It has short range and relatively weak signal compared to what I've been used to in other laptops (Intel and Atheros wifi cards), and Linux Mint wont even recognize it out-of the-box without manual driver download/install from software repos. I had to use the Alfa device to get these drivers, it recognized it without a hitch, as did Kali.I'm pretty sure it (the Broadcom) can't do packet injection and other advanced techniques, etc. The drivers for Alfa installed successfully each time, but I was never able to see 2 wifi adapter in the Taskbar notification area in the lower right of screen, whereas in 8 I could see both adapters if the Alfa was plugged. I can also see the Alfa in Control Panel, but cant seem to activate it for use. Whenever I would try, it would just seem to activate the Broadcom instead, which effective forced me to use the Net thru that. I'm not sure what else might be causing this, perhaps if you tell me what more info I can give, maybe I can find a solution here, or get advice on where I can go for help. I'm really not sure how else to explain it, since I'm not sure what the underlying cause is. I already posted in the Eight Forums, someone pasted back saying that I should try NetSetMan, which appears to be a WiFi profiles utility. I putzed around with it but it didnt seem to help, although interesting.

Well, thanks for the help in any case!

Link to comment
Share on other sites

Start reading here on packet injection with the broadcom 4313. It would've helped if you had been more specific about the broadcom device in your laptop and I know there is a different BCM device in use by Lenovo for the ThinkPad series aswell. So my current assumptions are:

You have a Lenovo ThinkPad, presumably Edge, possibly E130.

It comes with the BCM4313 but might instead have come with the BCM43228.

There apparenly was a 'b43' driver that presumably supported both and at least at some point did perform packet injection. At the time of death for the linked thread (2012) there was no working driver that did support this function. There are a bunch of links in that thread for you to investigate further, though.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...