Jump to content

SSLSTRIP + IPTABLES not redirecting traffic


Recommended Posts

Hello all, I am having an issue with redirecting traffic for sslstrip using iptables, I have tried to use these commands:

iptables -t nat -A PREROUTING -i wlan0 -p tcp --dport 80 -j REDIRECT --to-port 60000
iptables -t nat -A PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 60000

Which should redirect http traffic from port 80 to 60000, where I would have my sslstrip listening, however, nothing happens.

After applying the above rule I test using tcpdump -i wlan0 'port 60000' and no traffic is seen, while port 80 has traffic.
I have tried flushing all tables (iptables -F, iptables -t nat -F) and running the above rules, to no avail.

If anyone has any ideas any help would be appreciated.

Link to comment
Share on other sites

  • 4 weeks later...

I'm also having problems unable to get sslstrip running. It shows as running when in actual the browsing is still https. Can anyone PLEASE help me out here ?

If your browser has cached the sites you're trying to sslstrip, it won't work... The is because the cached links on the website will redirect you to the https site.

Edited by joharbi
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...