Jump to content

Client Mode join resets wlan0 and does not connect wlan1


Recommended Posts

  • What I do

    • Boot pineapple

  • Connect phone by wifi

WebInterface -> Network -> Client Mode

Select AP and enter password

Click Connect

What I expect to happen

  • Red LED to come on

RTL (wlan1) to connect to AP listed

Display connection information in the appropriate field

Pineapple and connected users to receive internet access through AP

What happens

  • Spinning pineapple connecting message appears

Blue light shuts off

I am disconnected

Blue light resumes flashing after a very short period

I can reconnect

When I reload the control panel wlan1 shows Disabled

Syslog pasted below

Extra info

  • If I change the wlan0 SSID without persisting it before doing this it is reset

if I enable wlan1 before clicking network it does NOT change behavior


Jan 1 00:05:15 Pineapple kern.info kernel: [ 380.180000] br-lan: port 2(wlan0) entered forwarding state

Jan 1 00:05:13 Pineapple kern.info kernel: [ 378.180000] br-lan: port 2(wlan0) entered forwarding state

Jan 1 00:05:13 Pineapple kern.info kernel: [ 378.170000] br-lan: port 2(wlan0) entered forwarding state

Jan 1 00:05:13 Pineapple kern.info kernel: [ 378.030000] device wlan0 entered promiscuous mode

Jan 1 00:05:12 Pineapple kern.info kernel: [ 376.520000] br-lan: port 2(wlan0) entered disabled state

Jan 1 00:05:12 Pineapple kern.info kernel: [ 376.520000] device wlan0 left promiscuous mode

Link to comment
Share on other sites

I found a work around... and even included my work!

  • found the script that is run by the webpage, that populates things with 'uci' and then runs wifi to reset all the interfaces (The reason I get disconnected)
  • ran wifi
  • got heaps of errors from /var/run/wpa_supplicant-wlan1
    • invalid password length 1 (expected 8..63) '$"'
    • failed to parse psk '"$"'
    • failed to parse network bock

At this point I'm assuming the system can't handle the wifi password being fed because it has a $???

  • check and delete file
  • reboot and it's regenerated by system.
  • read into /pineapple/components/system/network to find it uses uci to config things
  • find that uni uses /etc/config directory
  • find the wireless file and put the real password into it where there was just a $
  • reboot

we;lp pineapple boots and connects to desired AP and grants all my dreams and wishes... save for that bug where it didn't take my password and burnt several hours of my day.

Just to be sure;

  • WebInterface -> Network -> Client Mode
  • Disconnect
  • verify shows disconnected, wlan1 Disabled, and red light off
  • reboot pineapple with webinterface
  • Follow procedure listed in first post (What I Do) section
  • bug reproduced
  • fix password in /etc/config/wireless (option key '$passwordthathasaUSDsignjustlikethisone')
  • reboot (command line since I'm there)
  • workaround verified

Hopefully that should be more than enough to find said bug and repair...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...