Jump to content

ZTE MF112 3g dongle


UK_Steve
 Share

Recommended Posts

My ZTE MF112 3g dongle used to work with Firmware Version 1.0.4, but something changed in Firmware Version 1.1.0 which resulted in the modeswitch no longer switching. I had hoped that this would be fixed in Firmware Version 1.1.1, but it has not. Can anyone help ?

Link to comment
Share on other sites

I cannot think of a different issue as this is the only 3g dongle that is use with the Mark V. I just know that if I roll the Mark V back to 1.0.4 the modeswitch takes place and issuing ls -l /dev/ttyUSB* results in /dev/ttyUSB0, /dev/ttyUSB1 and /dev/tty/USB2 being detected whereas rolling the Mark V forward to 1.1.0 or 1.1.1 and issuing ls -l /dev/ttyUSB* results in "No such file or directory." I shall continue to compare 1.0.4 with 1.1.1, but any help or advice would be much appreciated.

Edited by UK_Steve
Link to comment
Share on other sites

I have a Pineapple Mark V running firmware 1.1.1 and would like to connect my ZTE MF70 3g USB Dongle.

I know that requires going into the Pineapple's Web Interface > Network tiles > Mobile Broadband tab but I would be grateful to know what values should be entered in the parameter list:

Interface Name:
Protocol:
Service:
Device:
APN:
Username:
Password:
Default Route:
ppp redial:
Peer DNS:
DNS:
Keepalive:
pppd options:

Edit : This thread goes a long way to answering my question:

https://forums.hak5.org/index.php?/topic/31889-3g-usb-for-you-for-me/

Edited by factgasm
Link to comment
Share on other sites

As explained in my original post my MF112 3g dongle no longer works with firmware 1.1.0 or 1.1.1, but when using firmware version 1.0.4 the Mobile Broadband Settings that work for me in the UK using a sim card from three.co.uk are as follows:-

Interface Name: ppp0
Protocol: 3g
Service: umts
Device: /dev/ttyUSB2 (if this device does not work try one of others listed after issuing ls -l /dev/ttyUSB*)
APN: 3internet
Username: leave blank
Password: leave blank
Default Route: 1
ppp redial: persist
Peer DNS: 0
DNS: 8.8.8.8
Keepalive: 1
pppd options: noauth

Hope this helps.

Link to comment
Share on other sites

It's working!

From memory, this is what I did from scratch to make it work:

1. I made sure that my Pineapple could share my Windows laptop's internet connection and that they were physically connected to each other by a LAN cable.

2. Plugged my dongle into my Pineapple.

3. PuTTYed into the Pineapple's Linux command line.

4. Ran these two commands:

opkg update

opkg install comgt kmod-usb-serial kmod-usb-serial-option kmod-usb-serial-wwan usb-modeswitch

5. Discovered that after running these commands I could plug the dongle straight into a laptop (Windows/Linux) and got an immediate connection to the internet without having to do anything else. Presumably this meant the mode-switch had worked.

6. I then plugged my dongle back into the Pineapple.

7. At the Pineapple's Linux command line I ran the command

lsusb

and made a note of the xxxx:xxxx hex number corresponding to my dongle (in my case 19d2:1405)

8. Still at the Pineapple's Linux command line I ran the commands:

cd /etc/usb_modeswitch.d

ls

and searched the list shown for a file that corresponded to my dongle's xxxx:xxxx number. As there was no such file in the list, I looked for a file whose name came close to my dongle's, but before it in sequence (19d2:1224 was closest).

9. To create a new file with the name 19d2:1405 but based on 19d2:1224 file I ran the Linux command:

cp 19d2:1224 19d2:1405

10. To edit this new file I typed

nano 19d2:1405

Thankfully the VID (19d2) was already correct but the dongle name and PID needed changing to MF70 and 1405 respectively.

11. I then saved and exited the file and also exited PuTTY too.

12. Using Firefox I went to the Pineapple's web interface (172.16.42.1:1471).

13. I clicked Network > Mobile Broadband and changed the settings to those shown here:

Interface Name: ppp0
Protocol: 3g
Service: cdma
Device: /dev/ttyUSB2
APN: [A code that should be printed on your dongle somewhere]
Username:


Password:

Default Route:1
ppp redial:persist
Peer DNS: 0
DNS: 8.8.8.8
Keepalive: 1
pppd options: noauth

14. I disconnected the LAN cable from my Pineapple and connected my laptop to it wirelessly instead, then PuTTYed back into the Pineapple again and typed the Linux command ping 8.8.8.8 - which worked!

15. On my Windows laptop using either Firefox or Internet Explorer I was able to surf the net while wirelessly connected to the Pineapple. I then tried the same with my Kali laptop and my two smart phones and was able to do the same with them too. Fantastic! Job done!

It works!

Please note that the order of these steps is mostly correct if not 100% correct. I don't think I missed out any steps. Some users might find that one or two of the steps are superfluous (sorry).

Either way I hope they serve as helpful pointers to anyone struggling the way I did. Now that I've successfully concluded the last two days of soul-destroying trial and error, I'd better go and make up with my other half!

Regards,

FG.

PS I did not have to make a ttyUSBn folder nor put anything in it.

PPS My Pineapple is using firmware 1.1.1. No rollback needed.

Final note : Credit goes to Madvinegar at this forum whose comments on mode-switching helped to assuage my doubts.

Edited by factgasm
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...