Jump to content

Trouble with Client Mode connect


Smokey
 Share

Recommended Posts

Hi,

My first post and unfortunatly it's about a problem that I got.

Device -> MK5, 1.0.4, Infusions [WifiMgr,Status,Site_Survey]. No ethernet cable connected

I'm trying to connect the MK5 to a Linksys WRT54G router that has open security (for test purpose at the moment).

I issued the "rm /etc/config/wireless && wifi detect > /etc/config/wireless && reboot" command to make sure the radio's aren't swapped.

Then after the reboot, I go to the network tile, client mode, dropdown to my Linksys router, click on Connect to this network.

It states, connecting, please wait. And Connection Information shows. Not connected.

So no connection....

But, when I SSH to the MK5 and manual do 'iwconfig wlan1 essid linksys && ifconfig wlan1 up && udhcpc -i wlan1'

The MK5 get's an IP from the Linksys and Internet is working on the MK5 :-)

But still of course, it's not sharing internet to wlan0.

Any clue what's going wrong with the client mode ?

/etc/config/wireless directly after the 'wifi detect..'

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option hwmode	11ng
	option macaddr	00:13:37:a5:11:5b
	option htmode	HT20
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     Pineapple5_115B
	option encryption none

config wifi-device  radio1
	option type     mac80211
	option channel  11
	option hwmode	11g
	option macaddr	1e:26:17:9f:4a:39

	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio1
	option network  lan
	option mode     ap
	option ssid     Pineapple5_4A39
	option encryption none

config wifi-device  radio2
	option type     mac80211
	option channel  11
	option hwmode	11g
	option macaddr	9e:af:6c:ac:9d:0a

	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio2
	option network  lan
	option mode     ap
	option ssid     Pineapple5_9D0A
	option encryption none
 

/etc/config/wireless after the 'Client Mode' connection failed :

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11ng'
	option macaddr '00:13:37:a5:11:5b'
	option htmode 'HT20'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'Pineapple5_115B'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option macaddr '9e:af:6c:ac:9d:0a'

config wifi-iface
	option device 'radio1'
	option mode 'sta'
	option network 'wan'
	option ssid 'linksys'

config wifi-device 'radio2'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option macaddr 'ea:6f:09:90:67:5d'

config wifi-iface
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'Pineapple5_675D'
	option encryption 'none'
  

Anybody any clue ?

Thanks,

Smokey

Edited by Mr-Protocol
Spoiler Tags
Link to comment
Share on other sites

So first of all the "wifi detect" command you are using is not a preventative measure. You only use it when you actually have a problem. If you are on the latest firmware your odds of the swap occurring have been greatly reduced. That being said, the wireless files you posted show you actually are suffering from a swap either because you are using a third wifi device plugged in or because it's plugged in and you used the "wifi detect" command. So unplug the third one, issue the wifi detect and reboot. Then try Client Mode tab to connect.

Link to comment
Share on other sites

@Lockon Did you try going through the tile interface?

Yes, that's the first thing I tried to do of course, but unfortunately that didn't work. That's when I tried to manual connect.

@thesugarat

I started out on Firmware 1.0, upgraded to 1.0.2, and within days 1.0.3 and 1.0.4

The reason why I used the 'wifi detect' was indeed because I thought they are swapped.

So unplug the third one, issue the wifi detect and reboot. Then try Client Mode tab to connect.

There is no third one connected to the device, only thing that is plugged into the device, is the Power Cable.

And there has never been a third wifi device connected to the device.

Which line of which config seems odd then ?

Link to comment
Share on other sites

I just did a factory reset to clear the config.

The /etc/config/wireless now looks like :

config wifi-device  radio0
	option type     mac80211
	option channel  11
	option hwmode	11ng
	option macaddr	00:13:37:a5:11:5b
	option htmode	HT20
	list ht_capab	SHORT-GI-20
	list ht_capab	SHORT-GI-40
	list ht_capab	RX-STBC1
	list ht_capab	DSSS_CCK-40
	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio0
	option network  lan
	option mode     ap
	option ssid     Pineapple5_115B
	option encryption none

config wifi-device  radio1
	option type     mac80211
	option channel  11
	option hwmode	11g
	option macaddr	b6:d6:f5:22:05:23

	# REMOVE THIS LINE TO ENABLE WIFI:
	# option disabled 1

config wifi-iface
	option device   radio1
	option network  lan
	option mode     ap
	option ssid     Pineapple5_0523
	option encryption none
 

Now there is no swap anymore right ?

Link to comment
Share on other sites

True, no longer swapped and the 3rd interface is gone. Now you can use the Client Mode Tab to connect with wlan1. It should clean up your wireless file and plance radio1 in the wan mode. You could also configure this using the WiFi Manager.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...