Jump to content

Boot DIP options


bionicrocky
 Share

Recommended Posts

Hello All,

I'm trying to get my MkV to start airmon/airodump and ssh to my relay server. The airmon portion seems to be working swimmingly. The SSH/and HTTP proxy through my relay do not seem to be initiating however. Below is the line I have added to the configuration for dip 010.

ifconfig wlan1 up; airmon-ng start wlan1; airodump-ng --write /sd/airodump.pcap --output-format pcap mon0; option ssh '-i /etc/dropbear/id_rsa -N -T -R 9434:localhost:1471 root@666.666.666.666'; option ssh '-i /etc/dropbear/id_rsa -N -T -R 999:localhost:22 root@666.666.666.666'

Any ideas why it is not auto-connecting to the relay?

Thanks in advance!!

Edited by bionicrocky
Link to comment
Share on other sites

  • 1 month later...

Darren, is autossh supposed to autostart at boot by default once properly configured?

I have set it up and it works fine to my VPS if i manualy hit connect in the webgui.

Am I supposed to add a connect command to one of the dip switch config lines? If so what command should I use?

An option in the small tile to 'autostart at boot' would make this less confusing.

AWSOME work to the whole team on the MKV by the way.

Cheers. :D

Link to comment
Share on other sites

You can add the following to your boot dip script:

/etc/init.d/autossh start >/dev/null &
Cheers mate. +1 for you. I will give it a try tomorrow. ;D Edited by 3mrgnc3
Link to comment
Share on other sites

You can add the following to your boot dip script:

/etc/init.d/autossh start >/dev/null &

Hmmn.. doesn't seem to be working as intended as a dip switch script.

I have experimented with adding a 3 min delay...

wait 180; /etc/init.d/autossh start >/dev/null &

I figured I would have to wait for my internet connection to be up before the command runs.

I can run your commands from the advanced tab in the webgui no problem.

should I just try a longer delay or is there a way to tell it only to run if an internet connection exists?

Thanks again for your help. :unsure:

Edited by 3mrgnc3
Link to comment
Share on other sites

The wait command is not intended for that. Try using sleep.

In my script I use a couple of sleep commands, it adds up to about 180 seconds so you should be fine with that. I think it doesn't even matter for autossh since it will keep trying to make a connection.

Link to comment
Share on other sites

Cheers.

I will try that. ;)

EDIT:

I tried it without any sleep or wait commands at the start of my boot script and it worked a treat!

Thanks again for all you tips. :D

Edited by 3mrgnc3
Link to comment
Share on other sites

  • 3 months later...

Hate to revive a dead thread, but I've been trying on and off all day to get this working on a DIP, with no luck.

Here is my DIP command line:

ifconfig wlan1 up; ifconfig wlan2 up; /etc/init.d/autossh start >/dev/null &

So wlan1 is coming up, wlan2 is not. autoSSH *is* coming on, but not connecting. I have to go into the GUI and turn it off/back on to get a connection. I also have the "autostart" option enabled. The internet connection is coming from the Raspberry Pie (kali) via eth port, so its already live and ready to go on Pineapple boot.

Any thoughts would be awesome.

Link to comment
Share on other sites

would check routing table on boot. Because you are stating that you are getting internet connection from eth0... as far as i know pine runs a DHCP server on boot on eth0 with no real default gateway.

side note: why would you enable wlan1 ? If you are getting a internet connection from eth0 ?

Link to comment
Share on other sites

would check routing table on boot. Because you are stating that you are getting internet connection from eth0... as far as i know pine runs a DHCP server on boot on eth0 with no real default gateway.

side note: why would you enable wlan1 ? If you are getting a internet connection from eth0 ?

I've left Kali running before, and rebooted the Pineapple multiple times. Always have an internet connection when it boots up.

Mainly turning them on for shiggles. I'm playing more with pentesting than MITM at this point. It's not a huge deal, but it's neat to already have all 3 radios up and running on a fresh boot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...