Jump to content

Search the Community

Showing results for tags 'autossh'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

Found 13 results

  1. Hello everybody I started up my LAN turtle for the first time today and have encountered many problems, this being the biggest. I was following Darrens tutorial for AutoSSH when this error popped up after pressing "copy_key" on the Key Manager module. "There was an error retrieving the key fingerprints." I saw a post similar to this but the solution presented did not work for me. https://forums.hak5.org/topic/37070-keymanager/ Im using the same cloud hosting service that Darren is using and its running Ubuntu 16. There are no problems PuTTY'ing into the LAN Turtle or the server. Any suggestions besides the one already posted? Michael
  2. Hello all. I have been watching the LAN Turtle 104 - Persistent Shell Access with AutoSSH video at https://www.youtube.com/watch?v=uIdvvrDrRj0 and at 5:15 it shows three fields for the setup, they are User@host, Remote Port & Local port. On my Turtle, which is probably a newer version of firmware than the one in the video, there is a fourth field simply named Port. As I understand it the Turtles local port is 22. It connects to the host via port 2222. Therefore on the host if you SSH to port 2222 it connects to the Turtle on it's port 22 through the 2222 tunnel. So you need a local port (22) and remote port (2222) to make this work, as shown in the demo video above. What is this extra field named 'Port' that I have, and what should it be set too? I entered 22 for this port and it all works. Just not clear what it's purpose is. Many thanks for any help. Tim
  3. Good day guys, I received my lan turtle a few weeks ago. It's been working great. I've had it setup to digitalocean box with Autossh Today I wanted to switch it over to my home office and have it autossh to a VM I'm probably missing something very basic. I've looked over the video Darren as done at for prescient shell and autossh Ok setup working backward. Kali Light (VM) - XenServer - Untangle router/firewall - Modem - Outside I have Untangle port forwarding to XXXX to Kali light to port 22 I'm able to make a SSH connection using XXXX from the outside fine. I've set up keys fine. But when logged into Kali Light and I try to loop back to the turtle by doing a ssh root@localhost -p 2222 I get an error Connect to host localhost port 2222: connection refused. Am I missing something very basic? it's usually the case lol... Thanks
  4. Hi, I have a problem with setting up autossh over ptunnel. Ptunnel working on xxx.xxx.xxx.xxx ptunnel host, local port 8000, dst. host yyy.yyy.yyy.yyy and dst. port 22. With ssh bar@localhost -p 8000 log's in to the yyy.yyy.yyy.yyy server. It is good. When I use autossh with bar@yyy.yyy.yyy.yyy, remote port 2222 and local port 22 I can connect back to lanturtle from yyy.yyy.yyy.yyy. So this config good too. But how to configure autossh, to go trough ptunnel? The documentation of ptunnel seems promising, but I have no luck to configure it: With this an autoSSH session to the SSH server running on example.com port 22 may be established through the Ping Tunnel via localhost port 8000. I setted up autossh with bar@localhost remote port 2222 and local port 8000, but it not working. How to setup ptunnel + autossh? Thanks in advance bar
  5. Hi, great little toy, though having some issues with sshfs. I managed to get autossh and sshfs to connect to a linux box i have on the net over tcp:443 without a hassle. Great posts from the forum and good videos. Thanks... autossh works as advertised, and starts on boot, within 60 seconds of connecting i am able to ssh in. However, i cannot seem to get sshfs to start on boot, and instead have to ssh in, use the turtle menu to start it or exit to the cli and type start sshfs. both autossh and sshfs exist in /etc/turtle/autostart_modules as symlinks to their respective /etc/turtle/modules/ files as called by /etc/init.d/turtle I have even tried to 'wrong way' to do things and set start sshfs in /etc/rc.local but with no avail. It would be helpful to have sshfs started on boot instead of having to connect to, and manually start on, or shortly after boot. any known fix?
  6. Hello, I recently received my Lanturtle, I set up autossh following Darren's video... When my lanturtle is connected to my computer I manage to ssh as root into localhost (ssh root@localhost -p 2222), however when I plug my lanturtle into a USB power source and connect it to my lan I cannot seem to ssh into it using the same technique. (ssh root@localhost -p 2222) Instead I get the error: ssh_exchange_identification: read: Connection reset by peer. Please Help! Thank you
  7. Frontend for autossh. In development Released - View/edit autossh configs - start/stop/enable/disable - create ssh key pairs - adds remote server to known_hosts https://github.com/audibleblink/autossh
  8. 2qik4u

    KeyManager

    Hi Guys Just unpacked my new Lan Turtle, all updated and patched with no problems... (thank you so much Hak5 team) Now setting up my AutoSSH for remote management and access to the target LAN The problem I am having is once the key pair are generated I try to copy the key to the host ssh server and receive an error "There was an error retrieving the key fingerprint" I am not sure if it's me (very much a newb) or if I have missed something, my cloud server is running Ubuntu 14.* LTS and is fully updated and patched. I have no problems SSH'ing to the server via putty or accessing the turtle via putty... Any idea's or suggestions would be much appreciated (be gentle) Kindest regards Simon London (UK)
  9. Hi I have enabled succesfully autossh in my markV, but something is happening that it's causing my device to reboot, this just happens if I'm connected to ssh remotely. I've checked the memory or cpu to see if the device is overloaded, but everything seems normal, what could be the cause?
  10. I've submitted some autossh feature requests including this one to support multiple port forwards and alternate SSH server ports. I know Seb has a lot on his plate before getting to these, so I was messing around and cloned AutoSSH, adding an "Advanced Settings" feature (mostly copy/pasting). Obviously, I can continue to modify the /etc/config/autossh file manually, but I wondered if this idea would get any traction, as it's so simple to implement. Basically, I just modified includes/content/setup.php to add the following: $args = exec("uci show autossh.@autossh[0].ssh | cut -f2- -d'='"); and: <br /> <fieldset> <legend>Advanced Settings</legend> <form method="POST" action="/components/infusions/myautossh/functions.php?action=advancededit" id="advancedAutossh" onSubmit="$(this).AJAXifyForm(update_message); return fals <table> <tr><td>Advanced args:</td><td><input name='args' type='text' placeholder='<?=$args?>' value='<?=$args?>' size='150'</td></tr> <tr><td><input type='submit' name='submit' value='Save'></td></tr> </table> </form> </fieldset> And modified functions.php to add: if($_GET['action'] == "advancededit"){ echo save_args($_POST['args']); } and: function save_args($args){ exec('uci set autossh.@autossh[0].ssh="'.$args.'"'); exec('uci commit autossh'); return "<font color='lime'>AutoSSH configuration updated.</font>"; } How would I make only one selected FieldSet/form active (Settings/Advanced Settings)? I use autossh for more than one port forward (22 & 1471), and my SSH server port isn't 22. I'd also like to be able to access a remote mysql (-L 3306:localhost:3306). This feature allows me to do that from the UI. Any thoughts or comments?
  11. Hello All, I'm trying to get my MkV to start airmon/airodump and ssh to my relay server. The airmon portion seems to be working swimmingly. The SSH/and HTTP proxy through my relay do not seem to be initiating however. Below is the line I have added to the configuration for dip 010. ifconfig wlan1 up; airmon-ng start wlan1; airodump-ng --write /sd/airodump.pcap --output-format pcap mon0; option ssh '-i /etc/dropbear/id_rsa -N -T -R 9434:localhost:1471 root@666.666.666.666'; option ssh '-i /etc/dropbear/id_rsa -N -T -R 999:localhost:22 root@666.666.666.666' Any ideas why it is not auto-connecting to the relay? Thanks in advance!!
  12. So after a week of everything I could possibly try I've come to the forums to discuss my Autossh Relay connection problem. I'm trying to reproduce Daren's relay server and Chriswat's tutorial and manage the gui remotely. Contents: MkV Virtual Ubuntu Server LTS 12.04 External Box Ubuntu Server LTS 12.04 Windows Putty Ubuntu 13.10 Virtual Phone Hotspot for External IP for MkV Ports: VM Ubuntu Server -p 7000 External Box Ubuntu Server -p 50456 MkV 1471:localhost:1471 First I have a Ubuntu Server 12.04 LTS box setup at work as a file server but it also has openssh-server installed. Then I setup port forwarding on the router and modem for 50456 to internal 22. I've tested this from hom and I can ssh just fine. I generated my public key for my MkV through putty and then ssh through the external IP to the port 50456 and it is now connected. root@Pineapple:~# ssh -p 50456 root@externalip I copied the pinapple public key to the authorized_keys for the server. I added the "AllowTcpForwarding yes" and "GatewayPorts yes" lines to the sshd_config, "service ssh restart". Then I logout. I do "ssh -p 50456 root@externalip -i /etc/dropbear/id_rsa" but for some reason I still have to enter the password. I don't know if I have to install dropbear on this particular server. But then I move on to installing my virtual ubuntu server. I do all the previous steps but this time I use 7000 as the forwarding external port and port 22 as the internal. I also have a ddns provided by asus as I have the Asus N66U router. "ssh -p 7000 root@externalip -i /etc/dropbear/id_rsa" This time I did not need to enter the password and now have an ssh connection from my pineapple to the server. I exit the ssh session. I then go to my web gui on the MkV then to the AutoSSH config and put in Host: root@externalip(VM) (I've also tried adding -p 7000) Port: 4567 Listen Port: 1471 I exit the configuration page and click connect for AutoSSH. Then I setup my phone for Mobile Hotspot and connect my MkV in client mode to my phone. I disconnect my ethernet cable connected to the MkV. I wait a few minutes for my pineapple to make a connection via AutoSSH. Next I power up my ubuntu 13.10 VM and make an SSH connection to my relay server "ssh -p 7000 root@externalip". I pull up a browser and type in externalip:4567. This does not work so I then try externalip:1471. This still doesn't work. I've tried to nail this down to a science before I posted on the forums about this. Please help. Thanks.
  13. I'm having some issues that began immediately after performing a factory reset. My issues pertain primarily to connectivity, client mode, and AutoSSH. Connectivity issues: 1) I cannot connect to my Pineapple AP when I use my Alfa AWUS036NHA (ar9271) USB network adapter with Kali Linux; however, I am able to connect with my Netgear (rtl8187) USB network adapter with Kali Linux. I'm also able to connect with my MacBook Pro, MacBook, and iMac's built-in network adapters. Only when trying to connect with my Alfa, I receive the error- "Unable to obtain an IP address." I've rebooted Kali, rebooted the Pineapple, factory reset the Pineapple, enabled/disabled the radios, changed my Alfa's MAC, and various other things. 2) Prior to performing the first factory reset, I did not have any problems with client mode. After the reset, however, I had the following problems: As soon as I'd use client mode, wlan0 would stop broadcasting permanently and wlan1 would not connect to the wireless network that I selected. To get wlan0 up again, I had to perform a factory reset. Eventually I found that both radios had the same MAC address, so I changed the MACs (in /etc/config/wireless) and the radios began to function again. Now the issue is that all of my Pineapple clients, with the exception of Mac OS X clients (VERY STRANGE), are disconnected immediately after enabling client mode. Issues with AutoSSH: 1) AutoSSH doesn't start on boot or remain persistent 2) If I manually use client mode to connect to a network after a fresh reboot, AutoSSH will not connect to my server although it indicates that it's connected. To get AutoSSH working, here's the procedure that I have to perform: a- Use the client mode tab to connect to the wireless network that I need for internet b- Reboot the Pineapple c- The Pineapple will automatically enable client mode and reconnect to the wireless network that I connected to prior to reboot. d- Click Connect in the AutoSSH tile This gets me connected to my server. However, when managing the Pineapple remotely, I depend on AutoSSH to start on boot and automatically connect after switching between networks in client mode. These issues are very frustrating. Insight is appreciated. Thanks.
×
×
  • Create New...