Jump to content

SSID Black / White Listing does not show mode


ScottHelme
 Share

Recommended Posts

In the Karma config tab the SSID Black / White Listing section doesn't show what mode it's currently in.

I had a dig in the code and it's trying to run this (/pineapple/components/system/karma/includes/content/config.php):

Currently in <?=exec('hostapd_cli -p /var/run/hostapd-phy0 karma_get_black_white')?> mode.

I changed it to remove the = as it didn't look right but that didn't help. Wild stab in the dark!

Originally spotted by +KaiserBuns on IRC.

Link to comment
Share on other sites

No problem here:


root@Pineapple:/sd/work# hostapd_cli -p /var/run/hostapd-phy0 karma_get_black_white

Selected interface 'wlan0'

BLACK

... although I might have radio0 and radio1 switched after a factory reset. So, here's my /etc/config/wireless for you to compare:


config wifi-device radio0

option type mac80211

option channel 11

option hwmode 11g

option macaddr 00:13:37:c0:ff:ee

option disabled '0'

config wifi-iface

option device radio0

option network wan

option hidden '0'

option mode sta

option ssid "myfi"

option key 'Betterhookmeuporelse'

option encryption 'psk2+tkip'

config wifi-device radio1

option type mac80211

option channel 'auto'

option hwmode 11ng

option macaddr 00:13:37:c0:0c:1e

option htmode HT20

list ht_capab SHORT-GI-20

list ht_capab SHORT-GI-40

list ht_capab RX-STBC1

list ht_capab DSSS_CCK-40

option disabled '0'

config wifi-iface

option device radio1

option network lan

option mode ap

option ssid "freewifi"

option encryption none

In this scenario I'm using radio0 to hookup to the Internet, and radio1 is my luring hotspot.

Edited by aibohphobia
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...