Jump to content

Cannot change Directory in FTP


Masterpyro
 Share

Recommended Posts

I have been trying to access my FTP at school to see how far my rainbow table is from completetion based on its size and after i log in, I can see everything in /home/user but after that access is denied and there is a 550 error. The ftp is ftp://masterpyro.no-ip.org and i want to get to /tools/passwords/rainbowcrack-.12/src/ to see my file. i have tried adding that to the end of the URL and that didnt work, I have used a webform to login to it and that allows me to see everything in / but still trying to change directories gives a 550 error.

Im stuck, any ideas?

Link to comment
Share on other sites

You won't want to create a shortcut, insted you want to create a symbolic link. Make sure the current working directory is currently /home/user/ and then do

ln -s /tools/passwords/rainbowcrack-.12/src

This will create a 'directory' in /home/user called src, when ever you cd to /home/user/src, you will actualy be accessing /tools/passwords/rainbowcrack-.12/src.

Link to comment
Share on other sites

Sounds a bit weird to me. There's nothing in the path that should make direct-access hard to do.

What FTP server are you using? Try logging in with a *real* ftp client. See if you can actually get the tools directory available to you in a directory listing. Your FTP server could be configured to not let you travel outsite /blah in which case that symbolic link won't help any either.

Link to comment
Share on other sites

550 = Access deinied? I can't remerb my error codes ;)

Well, if thats the case then it's most likly becasue the root user is the owner of the files and others arn't allowed to access them. The easist option is to do (as root)

chown -R user /home/user/src

replacing the word user with the users actual username of course. If you sudderly find that your hash generating ceces, then it's probably becasue you change the owner ship. The easist way around that is to run the hash geneartion as the limited user rather then root. Realy that problem shouldn't occure if you are running it as root, root has compleate access to every thing weather or not the file permissons say it is allowed to or not.

Link to comment
Share on other sites

What do you see when you access ftp://yourUser:YourPass@masterpyro.no-ip.org using your regular browser? I'm assuming you are in fact not using anonymous FTP (I've accessed it. There's nothing on there). There's a setting in your /etc/vsftpd.conf that chroots you to your home directory, meaning that every path you provide needs to be stripped from its '/home/yourUser' part. You'll see this instantly when you look at the directory listing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...