Jump to content

Miii Wifi Ip Address


Recommended Posts

So I was able to flash my MIII successfully and I am currently have it running. I used the ./wp3.sh to start the pineapple. I can see MACS in tha association logs. From my Windows 7 box I can see the 'internet' ssid and connect to it. Once connected I cannot get on the internet and when I do a IPCONFIG I get the following.....

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Networking.com

Link-local IPv6 Address . . . . . : fe80::84f0:b36c:7278:7041%11

IPv4 Address. . . . . . . . . . . : 192.168.10.36

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.10.2

Where is this .10.x network coming from? From the WEBif on the Pineapple I can see the routing table is 172.16.42.0. It looks like it is correct.

What can I do to check this and see why the 192.168.10.x is being giving by DHCP????

Thanks

Link to comment
Share on other sites

Any idea on this????? Where would I look to see whats doing dhcp? I have a strong networking background and a pretty OK linux skills. I am trying to find out where the Networking.com is coming from as well as the 192.168.10.x network.

I feel like I am getting close to getting this devise to work.

Thanks..

Link to comment
Share on other sites

Any idea on this????? Where would I look to see whats doing dhcp? I have a strong networking background and a pretty OK linux skills. I am trying to find out where the Networking.com is coming from as well as the 192.168.10.x network.

I feel like I am getting close to getting this devise to work.

Thanks..

I would say only plug in the power to your pineapple and not the network cable. Connect to the "pineapple" SSID and check your IP settings. Then browse to 172.16.41.1/pineapple and enable Karma. Disconnect from "pineapple" if it doesn't auto kick you off, and then connect to either "internet" or your open fake SSID.

Check IP settings again to see what you got.

Then move forward on trying to plug in the network to the pineapple to troubleshoot further. I sent you a request on skype btw.

Link to comment
Share on other sites

Thanks... I did what you said and connecting to the pineapple ssid I did get a 172.16.42.238 IP address. I then connected the cable to my laptop and ran wp3.sh I started seeing a ton of devices connected and getting a 172.16.42.x addresses. I then connected my laptop to the internet ssid and got a 192.168.10.26 IP address but in the pineapple webif I saw my laptops mac address on the ARP log with an address of 172.16.42.248 I connect my phone to the 'internet' ssid and see it on the webif as 172.16.42.248 but on the phone I see a 192.168.10.3 address and cannot get to the internet.

Very weird. I tried calling on skype but I guess there is a time difference and your asleep.

Link to comment
Share on other sites

So I reflashed my pineapple like Mr.Protocol suggested and went to a different wifi network. I am still getting a 192.168.10.x sent out on dhcp. Where should I be looking for this? This is getting frustrating.

Anyone have any ideas???????:angry:

Link to comment
Share on other sites

It would be in the DHCP part of the advanced or configuration on the interface. Not sure why you are getting the 192 though. I am running on no sleep so I'm out of ideas.

Thanks for all your help. I have a long drive back to California so when I get home I am going to dig into this but if anyone has any ideas please let me know.......

Link to comment
Share on other sites

Thanks for all your help. I have a long drive back to California so when I get home I am going to dig into this but if anyone has any ideas please let me know.......

I'll be back home later on tonight and mucking about with my setup, so I'll try to assist, if you can provide some info below I'll see what I can offer:

- Windows 7?

- Laptop?

- Using internal laptop wireless to provide Internet, and laptop eth0 to connect to MK3?

- Are you configured per the Quick Start guide?

Drive safe. ;)

Link to comment
Share on other sites

I'll be back home later on tonight and mucking about with my setup, so I'll try to assist, if you can provide some info below I'll see what I can offer:

- Windows 7?

- Laptop?

- Using internal laptop wireless to provide Internet, and laptop eth0 to connect to MK3?

- Are you configured per the Quick Start guide?

Drive safe. ;)

Thanks.....The laptop I am running this is on is Backtrack 5 which is installed and not a live cd. I am using a netgear USB wifi (wlan0) and nic (eth0) connected to the MK3. I use my Windows 7 laptop to test with.

I use the ./wp3.sh to start it.

Edited by Mother
Link to comment
Share on other sites

OK, So I am home know and have it set up on my home network. I am experiencing the same issue.

I am trying to grep "192.168.10.2" which is the gateway I am always getting when I connect to the "internet" ssid but havent found anything yet. Does anyone have any idea on what the hell is going on? I guess I am the only one dealing with issue.

This the ipconfig from the Win 7 laptop when I connect to the pineapple and pull an address........

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Networking.com

Description . . . . . . . . . . . : Intel® WiFi Link 5100 AGN

Physical Address. . . . . . . . . : 00-24-D6-6A-91-14

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Link-local IPv6 Address . . . . . : fe80::84f0:b36c:7278:7041%11(Preferred)

IPv4 Address. . . . . . . . . . . : 192.168.10.36(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Lease Obtained. . . . . . . . . . : Saturday, December 10, 2011 4:53:03 PM

Lease Expires . . . . . . . . . . : Saturday, December 10, 2011 4:54:15 PM

Default Gateway . . . . . . . . . : 192.168.10.2

DHCP Server . . . . . . . . . . . : 255.255.255.255

DHCPv6 IAID . . . . . . . . . . . : 218113238

DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-56-39-2D-00-26-B9-96-08-A7

DNS Servers . . . . . . . . . . . : 192.168.10.2

NetBIOS over Tcpip. . . . . . . . : Enabled

Link to comment
Share on other sites

OK, So I am home know and have it set up on my home network. I am experiencing the same issue.

I am trying to grep "192.168.10.2" which is the gateway I am always getting when I connect to the "internet" ssid but havent found anything yet. Does anyone have any idea on what the hell is going on? I guess I am the only one dealing with issue.

This the ipconfig from the Win 7 laptop when I connect to the pineapple and pull an address........

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Networking.com

Description . . . . . . . . . . . : Intel® WiFi Link 5100 AGN

Physical Address. . . . . . . . . : 00-24-D6-6A-91-14

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Link-local IPv6 Address . . . . . : fe80::84f0:b36c:7278:7041%11(Preferred)

IPv4 Address. . . . . . . . . . . : 192.168.10.36(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Lease Obtained. . . . . . . . . . : Saturday, December 10, 2011 4:53:03 PM

Lease Expires . . . . . . . . . . : Saturday, December 10, 2011 4:54:15 PM

Default Gateway . . . . . . . . . : 192.168.10.2

DHCP Server . . . . . . . . . . . : 255.255.255.255

DHCPv6 IAID . . . . . . . . . . . : 218113238

DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-16-56-39-2D-00-26-B9-96-08-A7

DNS Servers . . . . . . . . . . . : 192.168.10.2

NetBIOS over Tcpip. . . . . . . . : Enabled

Do you have another wireless device you can try? Something strange is going look at the DHCP server its listed as 255.255.255.255.

I have only had that be correct on PPP connections...

Link to comment
Share on other sites

Here is the config from the pineapple

Network

# Copyright © 2006 OpenWrt.org

config interface loopback

option ifname lo

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

config interface lan

option ifname eth0

option type bridge

option proto static

option ipaddr 172.16.42.1

option netmask 255.255.255.0

option gateway 172.16.42.42

option dns 8.8.8.8

DHCP

config 'dnsmasq'

option 'domainneeded' '1'

option 'boguspriv' '1'

option 'filterwin2k' '0'

option 'localise_queries' '1'

option 'rebind_protection' '1'

option 'rebind_localhost' '1'

option 'local' '/lan/'

option 'domain' 'lan'

option 'expandhosts' '1'

option 'nonegcache' '0'

option 'authoritative' '1'

option 'readethers' '1'

option 'leasefile' '/tmp/dhcp.leases'

option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan'

option 'interface' 'lan'

option 'start' '100'

option 'limit' '150'

option 'leasetime' '12h'

option 'ignore' '0'

list 'dhcp_option' '3,172.16.42.42'

list 'dhcp_option' '6,172.16.42.1,8.8.8.8'

list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

config 'dhcp' 'wan'

option 'interface' 'wan'

option 'ignore' '1'

option 'start' '100'

option 'limit' '150'

option 'leasetime' '12h'

list 'dhcp_option' '3,172.16.42.42'

list 'dhcp_option' '6,172.16.42.1,8.8.8.8'

list 'dhcp_option' '6,172.16.42.1,208.67.222.222'

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...