Jump to content

Wi-fi Issue With Backtrack 4


Snap
 Share

Recommended Posts

I recently purchased an Acer Aspire One, and have tried everything I can to figure out how to make the Wi-Fi work. I have tried several drivers and to no avail, so I turn here for some help. My wireless card shows up as Broadcom Corporation Device [14e4:4727] (rev 01). I figured this net book would be compatible with Backtrack because others have said it worked out of the box. Any help would be appreciated and I will do my best to provide you with info. Thanks.

Link to comment
Share on other sites

ifconfig... locate your wireless then

aircmon-ng start wlan0

should give you wlan0 up, mon0 up

then issues you command using interface mon0

Edited by buffy
Link to comment
Share on other sites

That looks like the Broadcom BCM4313 card, but depends on the broadcom chip. Most of the broadcom ones don't work well with bt other than just for surfing the web, as some won't be able to do monitor mode or injection. Just depends on the chip itself, but first thing you need to know, is if it even shows up. Its been mentioned above about wicd and looking for the hardware key to turn it on(usualy a combination of a FN key with one of the F buttons, for example "FN + F2" or "FN + Numkey 2", actual key may vary)

Issue:

ifconfig -a

in a console and see what cards are listed. you should see something like eth0, lo and wlan0, where wlan0 is your wireless card. If all you see is eth0 and lo, then you probably need to load or probe for the appropriate driver, which might not even be on the BT disc.

See here for help with similar broadcom cards:

http://www.backtrack-linux.org/wiki/index.php/Broadcom_wl

If your card shows up under wlan0 but won't come up might need the hardware key combo to enable the radio first, then try the "ifconfig wlan0 up" command.

Link to comment
Share on other sites

Broadcom does work, I have a BCM 4306 and works with BT4 R2.

iwconfig <- see wireless

buffy had a typo: airmon-ng *iface* start

Yes, but there are many different Broadcom chipsets, some which don't work well, or even at all with BT. For example, my old laptop has an internal broadcom that works ok in bt, but it doesn't do injection.

Link to comment
Share on other sites

What shows up when I type ifconfig is the following:

lo	Link encap:Local Loopback
	inet addr:127.0.0.1 Mask:255.0.0.0
	UP LOOPBACK RUNNING MTU:16436 Metric:1
	RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
	collisions:0 txqueuelen:0
	RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

and for iwconfig:

lo	no wireless extensions

I'm pretty sure my Wi-Fi isn't even toggled on (the light for it is orange-ish), and that's the issue. But, I am unable to toggle it using the function key designated to it. All the other function keys work though which is the confusing part. Possible driver issue I've investigated also.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...