Jump to content

Pptp Serve On Dd-wrt


Jamo
 Share

Recommended Posts

Hi.

I have ASUS RT-N16. I have flashed it to DD-WRT mega. It has build in pptp-server. I have configured server correctly, Im able to connect to my pptp-vpn-server from wlan using my iPod touch.

But, when Im not in my home lan In not able to connect to my pptp-vpn-server.

i have checked that port 1723 is open. canyouseeme.com

I have tried to forward that port to my router.

My config

root@DD-WRT:~# cat /tmp/pptpd/options.pptpd 
lock
name *
proxyarp
ipcp-accept-local
ipcp-accept-remote
lcp-echo-failure 10
lcp-echo-interval 5
deflate 0
auth
-chap
-mschap
+mschap-v2
mppe required,stateless
mppc
ms-ignore-domain
chap-secrets /tmp/pptpd/chap-secrets
ip-up-script /tmp/pptpd/ip-up
ip-down-script /tmp/pptpd/ip-down
mtu 1450
mru 1450
ms-dns 192.168.1.1
ms-dns 8.8.8.8
ms-dns 8.8.4.4

So what wrong?

Link to comment
Share on other sites

Hi.

I have ASUS RT-N16. I have flashed it to DD-WRT mega. It has build in pptp-server. I have configured server correctly, Im able to connect to my pptp-vpn-server from wlan using my iPod touch.

But, when Im not in my home lan In not able to connect to my pptp-vpn-server.

i have checked that port 1723 is open. canyouseeme.com

I have tried to forward that port to my router.

My config

root@DD-WRT:~# cat /tmp/pptpd/options.pptpd 
lock
name *
proxyarp
ipcp-accept-local
ipcp-accept-remote
lcp-echo-failure 10
lcp-echo-interval 5
deflate 0
auth
-chap
-mschap
+mschap-v2
mppe required,stateless
mppc
ms-ignore-domain
chap-secrets /tmp/pptpd/chap-secrets
ip-up-script /tmp/pptpd/ip-up
ip-down-script /tmp/pptpd/ip-down
mtu 1450
mru 1450
ms-dns 192.168.1.1
ms-dns 8.8.8.8
ms-dns 8.8.4.4

So what wrong?

I've used DD-WRT PPTP before without any issues although I'm all windows based. Not sure if there is an issue with your conif, but what error message are you getting and what client are you using to connect?

Link to comment
Share on other sites

I've used DD-WRT PPTP before without any issues although I'm all windows based. Not sure if there is an issue with your conif, but what error message are you getting and what client are you using to connect?

No error messages, just couldn't connect. I was trying with ubuntu laptop and iPod touch.

When I forwarded that pptp port to my router it started to work. So I got it working.

Link to comment
Share on other sites

Not sure if that will make any difference, but try setting an IP range for your network in the config file.

For example:

localip 192.168.0.1

remoteip 192.168.0.234-238,192.168.0.245

Refer to this link, if you are not sure.

http://poptop.sourceforge.net/dox/debian-howto.phtml

Link to comment
Share on other sites

Not sure if that will make any difference, but try setting an IP range for your network in the config file.

For example:

localip 192.168.0.1

remoteip 192.168.0.234-238,192.168.0.245

Refer to this link, if you are not sure.

http://poptop.sourceforge.net/dox/debian-howto.phtml

In web gui I have set ip range for vpn user. It seems, that thats not in that text config.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...