Jump to content

Armitage


c0r
 Share

Recommended Posts

I like it already, its a like sitting in front of a TV playing video game, you get to see what is happening in real time or sort of.

Link to comment
Share on other sites

i actually got this installed on backtrack but i have never been able to get it working even followed this guide only changed to toor password to my own. and each time it says "something went wrong: tried: @(msf.RpcConnection@5bcd91, 'console.destory', '0')"

http://www.offensive-security.com/backtrack/armitage-in-backtrack-4-r2/

dont know what to do

Link to comment
Share on other sites

yeah im getting this error

java.lang.RuntimeException: Error reading response.
        at msf.RpcConnection.readResp(RpcConnection.java:137)
        at msf.RpcConnection.exec(RpcConnection.java:66)
        at msf.RpcConnection.cacheExecute(RpcConnection.java:261)
        at msf.RpcConnection.execute(RpcConnection.java:239)
        at armitage.CommandClient.exec(CommandClient.java:65)
        at armitage.CommandClient.run(CommandClient.java:41)
        at java.lang.Thread.run(Thread.java:619)
Warning: invalid use of index operator: $null['driver'] at util.sl:132

Link to comment
Share on other sites

right.

but when i got to java -version

i get

The program 'java' can be found in the following packages:

* java-gcj-compat-headless

* cacao-oj6-jre-headless

* gij-4.2

* kaffe

* cacao

* openjdk-6-jre-headless

* jamvm

* gij-4.3

* sablevm

Try: apt-get install <selected package>

Edited by ParMan
Link to comment
Share on other sites

I've got this

root@bt:~/Scripts/armitage# java -version

java version "1.6.0_10"

Java SE Runtime Environment (build 1.6.0_10-b33)

Java HotSpot Server VM (build 11.0-b15, mixed mode)

c

im lost then i downloaded it to root desktop

then i ran chmod +x filename

then i ran ./file name installed it said done.

everything broke.

now what?

Link to comment
Share on other sites

so i reinstalled the java that i removed and now i get the same thing you have

java version "1.6.0_10"
Java™ SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot™ Server VM (build 11.0-b15, mixed mode)

but i still get the same error

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...