Jump to content

Karma Stopping


Recommended Posts

:blink:I have just got the custom firmware with jasager up and going. The only issue that i seam to be facing is that every time I start karma is dies. I hit the refresh on my jasager web interface and it shows karma as off. Also when I have karma on it is not actually working (on my test machine everything looks normal as far as the SSIDs showing available. Also I show a open wrt SSID in the list. I had some issues flashing the fon using the ap51-flash-fonera-gui-1.0-38 it looked like it was trying to flash my wifi interface base on the MAC address shown. I ended up having to flash open wrt using redboot interface via telnet to 192.168.1.254 port 9000. I followed this guide for setup (except for the redboot firmware flashing part for that I used http://wiki.openwrt.org/toh/fon/fonera#ins...rt.with.redboot

substituting the openwrt-atheros-2.6-vmlinux.lzma and the openwrt-atheros-2.6-root.squashfs where it called for. Below is my session starting after the openwrt firmware. Any help would be greatly appreciated and thanks in advance.

=== IMPORTANT ============================

Use 'passwd' to set your login password

this will disable telnet and enable SSH

-----------------------------------------

BusyBox v1.4.2 (2007-09-29 07:21:40 CEST) Built-in shell (ash)

Enter 'help' for a list of built-in commands.

_______ ________ __

| |.-----.-----.-----.| | | |.----.| |_

| - || _ | -__| || | | || _|| _|

|_______|| __|_____|__|__||________||__| |____|

|__| W I R E L E S S F R E E D O M

KAMIKAZE (7.09) -----------------------------------

* 10 oz Vodka Shake well with ice and strain

* 10 oz Triple sec mixture into 10 shot glasses.

* 10 oz lime juice Salute!

---------------------------------------------------

root@OpenWrt:/# passwd

Changing password for root

New password:

Bad password: too weak

Retype password:

Password for root changed by root

root@OpenWrt:/# passwd

Changing password for root

New password:

Retype password:

Password for root changed by root

root@OpenWrt:/# uci set wireless.wifi0.disabled=0

root@OpenWrt:/# uci commit wireless && wifi

root@OpenWrt:/# cd /tmp/

root@OpenWrt:~# ipkg install haserl_0.8.0-2_mips.ipk

Installing haserl (0.8.0-2) to root...

Configuring haserl

Done.

root@OpenWrt:~# ipkg install webif_0.3-10_mips.ipk

Installing webif (0.3-10) to root...

Configuring webif

Linux OpenWrt 2.6.21.5 #2 Sun Sep 30 20:16:16 CEST 2007 mips unknown

Linux OpenWrt 2.6.21.5 #2 Sun Sep 30 20:16:16 CEST 2007 mips unknown

system type : Atheros AR2315

Linux OpenWrt 2.6.21.5 #2 Sun Sep 30 20:16:16 CEST 2007 mips unknown

Downloading http://downloads.openwrt.org/kamikaze/7.09...6/packages/Pack

ages

wget: bad address 'downloads.openwrt.org'

Downloading http://downloads.openwrt.org/kamikaze/packages/mips/Packages

wget: bad address 'downloads.openwrt.org'

Downloading http://downloads.x-wrt.org/xwrt/kamikaze/7...-2.6/packages/P

ackages

wget: bad address 'downloads.x-wrt.org'

An error ocurred, return value: 3.

Collected errors:

ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp

-q -P /tmp/ipkg-vywPZM http://downloads.openwrt.org/kamikaze/7.09/atheros-2.6/p

ackages/Packages'

ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp

-q -P /tmp/ipkg-vywPZM http://downloads.openwrt.org/kamikaze/packages/mips/Pack

ages'

ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp

-q -P /tmp/ipkg-vywPZM http://downloads.x-wrt.org/xwrt/kamikaze/7.09/atheros-2.

6/packages/Packages'

Committing new firmware id ...

Device: La Fonera (ACCTON MR3201A)

Committing new device id ...

SUCCESS! Webif^2 installation appears OK. Welcome to X-Wrt!

You may need to do a hard REFRESH to clear old CSS style from your browser.

Reinitializing httpd ...

Done.

root@OpenWrt:~# ipkg install libruby_1.8.6-p36-1_mips.ipk

Installing libruby (1.8.6-p36-1) to root...

Configuring libruby

Done.

root@OpenWrt:~# ipkg install ruby_1.8.6-p36-1_mips.ipk

Installing ruby (1.8.6-p36-1) to root...

Configuring ruby

Done.

root@OpenWrt:~# ipkg install ruby-core_1.8.6-p36-1_mips.ipk

Installing ruby-core (1.8.6-p36-1) to root...

Configuring ruby-core

Done.

root@OpenWrt:~# ipkg install ruby-rexml_1.8.6-p36-1_mips.ipk

Installing ruby-rexml (1.8.6-p36-1) to root...

Configuring ruby-rexml

Done.

root@OpenWrt:~# ipkg install jasager-madwifi_1.ipk

Installing kmod-madwifi (2.6.21.5+r2568-20070710-atheros-2) to root...

Configuring kmod-madwifi

Done.

root@OpenWrt:~# ipkg install kmod-gpio_2.6.21.5-atheros-1_mips.ipk

Installing kmod-gpio (2.6.21.5-atheros-1) to root...

Configuring kmod-gpio

Done.

root@OpenWrt:~# ipkg install jasager_2.1.ipk

Installing jasager (2) to root...

Configuring jasager

Install finished, testing that it worked ok

SUCCESS! Jasager installation appears OK. Welcome to Jasager!

To view the web interface please visit http://<fon>:1471/

Stopping any currently running Jasager sessions

killall: tail: no process killed

killall: logwatch: no process killed

Starting Jasager

Link to comment
Share on other sites

Flash with my firmware and you won't have to worry about installing individual ipks.

Looking at that though the process worked OK. The first thing it does after an install is to stop Jasager if it is already running then starts it fresh. The no process killed messages are because it wasn't already running.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...