Jump to content

Missing OpenWrt GUI


Recommended Posts

After flashing with the v1 firmware from the digininja web site, I connected to the Jasager karma web page at 192.168.1.1:1471 and fired up the interface. Using another laptop I created a test SSID and Jasager connected me and I could see the connection in the Jasager web page. So far, so good.

The trouble is I cannot find the OpenWrt GUI to make further configuration changes. I assumed the OpenWrt web page would be at 192.168.1.1/webif.html or 192.168.1.1:1471/webif.html based on the detailed step by step instructions.

So, after messing around for a while I gave up returned to step 11 and reflashed using the step by step instructions - those did not include using the v1 firmware. It seems to all work now. So does the v1 firmware include everything that is included in the step by step instructions (i.e steps 11-20 from http://hak5.org/forums/index.php?showtopic=9908) ? Just curious at this point.

Thanks.

Link to comment
Share on other sites

ok as for the ipkg issue...... use opkg instead.....

still no openwrt gui though....shame as jasager is working fine but i need the wrt gui.

im going to reflash from step 11 using the firmware and package installs.

i cant belive nobody else is getting this problem using the all in one flash? the openwrt gui is just not there?

Link to comment
Share on other sites

root@OpenWrt:~# echo "src X-Wrt hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages" >> /etc/opkg.conf

replace hxxp with http, this was to prevent the forum from auto concatenation

root@OpenWrt:~# opkg update

root@OpenWrt:~#opkg remove -recursive luci-*

root@OpenWrt:~# opkg update

root@OpenWrt:~# opkg install webif

root@OpenWrt:~# reboot

Point your browser to http://192.168.1.1

Link to comment
Share on other sites

root@OpenWrt:~# echo "src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8.../packages"

>> /etc/opkg.conf

root@OpenWrt:~# opkg update

Downloading http://downloads.openwrt.org/kamikaze/8.09...ges/Packages.gz

wget: bad address 'downloads.openwrt.org'

Downloading hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages/Packages

wget: not an http or ftp url: hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages/Packages

Collected errors:

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

Looks odd......any idea whats going wrong...why is it trying to wget: bad address 'downloads.openwrt.org'

I dont really want to reflash as its working on Jasager.

thanks for helping

Link to comment
Share on other sites

OK ive done it!!

For referance this is the method which worked for me. Basically following this post by the Fungus.

http://hak5.org/forums/index.php?showtopic...st=#entry134593

Ran this first to remove my previous attempts at webif.

opkg -recursive remove haserl

Downloaded and moved these files to the tmp directory on the fon using winSCP

haserl_0.9.24-1_mips.ipk

webif_0.3-4709_mips.ipk

webif-theme-xwrt_0.3-4709_all.ipk

Installed the files using putty.

opkg install haserl_0.9.24-1_mips.ipk

opkg install webif_0.3-4709_mips.ipk

opkg install webif-theme-xwrt_0.3-4709_all.ipk

Got both interfaces now at

192.168.1.1

192.168.1.1:1471

Link to comment
Share on other sites

root@OpenWrt:~# echo "src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8.../packages"

>> /etc/opkg.conf

root@OpenWrt:~# opkg update

Downloading http://downloads.openwrt.org/kamikaze/8.09...ges/Packages.gz

wget: bad address 'downloads.openwrt.org'

Downloading hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages/Packages

wget: not an http or ftp url: hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages/Packages

Collected errors:

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

* ERROR: duplicate src declaration. Skipping:

Looks odd......any idea whats going wrong...why is it trying to wget: bad address 'downloads.openwrt.org'

I dont really want to reflash as its working on Jasager.

thanks for helping

Yes, you failed reading comprehension 101.

You've got x-wrt defined 4 times defined in your opkg.conf . Once as hxxp which won't work and you've got in there at http 3 more times. You only need it once. The "bad address 'downloads.openwrt.org" means your Fon couldn't get to the openwrt site for updates. You'll want to edit your opkg.conf manually and get rid of the crap now.

Basically, you ended up doing everything manually by scp the files over and installing them locally. In the end you got it right so you get 2 points out of a possible 5.

Link to comment
Share on other sites

Yes, you failed reading comprehension 101.

You've got x-wrt defined 4 times defined in your opkg.conf . Once as hxxp which won't work and you've got in there at http 3 more times. You only need it once. The "bad address 'downloads.openwrt.org" means your Fon couldn't get to the openwrt site for updates. You'll want to edit your opkg.conf manually and get rid of the crap now.

Basically, you ended up doing everything manually by scp the files over and installing them locally. In the end you got it right so you get 2 points out of a possible 5.

thanks for the help m8.....i did open up the opkg.conf in an editor and could see all the incorrect address in there. problem was i would have thought it would pick up the correct one anyway and was unsure whether to mess about in there too much. thing is there was other 'stuff' in that file so have no idea what exactly the contents should look like.

i aslo had no idea what your command was doing untill now. you were basically 'editing' the file with the correct contents.

anyway here is file contents after i 'cleaned' it up a bit. can you correct it for me. thanks.

src/gz snapshots http://downloads.openwrt.org/kamikaze/8.09/atheros/packages

dest root /

dest ram /tmp

lists_dir ext /var/opkg-lists

option overlay_root /jffs

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

Link to comment
Share on other sites

thanks for the help m8.....i did open up the opkg.conf in an editor and could see all the incorrect address in there. problem was i would have thought it would pick up the correct one anyway and was unsure whether to mess about in there too much. thing is there was other 'stuff' in that file so have no idea what exactly the contents should look like.

i aslo had no idea what your command was doing untill now. you were basically 'editing' the file with the correct contents.

anyway here is file contents after i 'cleaned' it up a bit. can you correct it for me. thanks.

src/gz snapshots http://downloads.openwrt.org/kamikaze/8.09/atheros/packages

dest root /

dest ram /tmp

lists_dir ext /var/opkg-lists

option overlay_root /jffs

src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaze/8...theros/packages

Looks good doing an opkg update should verify. Then you could run opkg install webif and you should have the latest x-wrt interface.

Link to comment
Share on other sites

  • 2 months later...

I had a similar problem to NoOne when trying to install webif with this method...

root@OpenWrt:~# echo "src X-Wrt hxxp://downloads.x-wrt.org/xwrt/kamikaze/8.09/atheros/packages" >> /etc/opkg.conf

replace hxxp with http

root@OpenWrt:~# opkg update

root@OpenWrt:~#opkg remove -recursive luci-*

root@OpenWrt:~# opkg update

root@OpenWrt:~# opkg install webif

root@OpenWrt:~# reboot

Ran this first to remove my previous attempts at webif.

opkg -recursive remove haserl

so I followed NoOnes manual install method and got it to install ok

Downloaded and moved these files to the tmp directory on the fon using winSCP

haserl_0.9.24-1_mips.ipk

webif_0.3-4709_mips.ipk

webif-theme-xwrt_0.3-4709_all.ipk

after changing from root@OpenWrt~# to tmp and commencing install :

Installed the files using putty.

opkg install haserl_0.9.24-1_mips.ipk

opkg install webif_0.3-4709_mips.ipk

opkg install webif-theme-xwrt_0.3-4709_all.ipk

Got both interfaces now at

192.168.1.1

192.168.1.1:1471

Another step over.... thanx all. :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...