Jump to content

No Internet over PPTP


Q-tip
 Share

Recommended Posts

Straight to the point: I can connect into my VPN server, but I have no Internet access after that. I've seen numerous posts on Google saying "Oh, you're stupid, don't use the default gateway. Just uncheck the box at [such a location] in Windows." Problem is, one of my clients is Ubuntu, and the other is an iPod Touch. Plus, I want my traffic to use the VPN as a gateway as a security measure on open networks. I've become quite frustrated with Google trying to figure this out, so I came to the source. HALP!

EDIT: A recap of my replies in this thread:

  • I'd like to reiterate that I have no problem connecting to the VPN server, even from a remote network.
  • My VPN clients get an address from the range I specified in the VPN server. If I change it to give addresses from DHCP, VPN clients cannot connect at all.
  • The firewall on the VPN server is down. It sits behind a router with only the necessary ports forwarded.

And a side note: The WRT54G v8 is capable of running Micro DD-WRT, which (correct me if I'm wrong) doesn't support running a VPN server on the router itself.

Link to comment
Share on other sites

do you have the pptp server set to forward http traffic onto the server isp? I tried to do the same thing but i could not get the remote conection to get http traffic to pass though the pptp connection. I gave up and came back later and discovered a great feature in DD-WRT pptp server. Sorry i can't help you more with setting up the ubuntu server (i assume) to be you pptp gateway.

Link to comment
Share on other sites

... did you open the proper ports on your switch? I noticed you said it was a V.8. so I do not think you would be using DD-WRT.. Those linksys firmwares can be kind of finicky on the wrt models... lest as far as I have known.

Link to comment
Share on other sites

Do the connecting clients get the IP address assigned by the DHCP server on the remote network or the XP machine?

If they do get IP addresses from DHCP you need to make sure that your default gateway is specified as the routers/gateways IP address not the computer running the VPN server.

Link to comment
Share on other sites

... did you open the proper ports on your switch? I noticed you said it was a V.8. so I do not think you would be using DD-WRT.. Those linksys firmwares can be kind of finicky on the wrt models... lest as far as I have known.

I have no problem connecting to the VPN server.

Do the connecting clients get the IP address assigned by the DHCP server on the remote network or the XP machine?

If they do get IP addresses from DHCP you need to make sure that your default gateway is specified as the routers/gateways IP address not the computer running the VPN server.

The VPN clients get the IP's from the VPN server, which is a 10.10.*.* address. My LAN addresses are 192.168.*.* addresses. The intuitive thing for me would be to turn on Internet Connection Sharing, but Incoming Connections isn't on the list of NIC's I can share with. I'm out of ideas. Has anyone gotten what I've described to work or have another solution that does what I'm trying to do?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...