Jump to content

Fon Serial Cable Problems


loftrat
 Share

Recommended Posts

Me Again :D

Ok, I've got a serial cable made up - USB to some header connectors which are currently plugged into th Ground, RX, and TX, pins on the Fon + mainboard.

Putty (in Windows) doesn't seem to want to play. This seems to be because Windows doesn't want anything to do with the Fon when I plug it it - it just complains that the USB device has failed/errored and keeps doing that over and over and over.

Linux doesn't seem to recognise it either -it proudly tells me (via dmesg) that it's found a new device (using uhci-hcd and address 97), then tells me that it's 'failed to enumerate USB device on port 1'.

If I run dmesg again I get the same message, only it's now 98, then 99, then 100, etc.

I've checked and double checked the pin connections on the cable, and they're fine. I've tried the RX cable on the TX pin and vice versa.

Anybody got any thoughts on where I can go from here?

Thanks :)

Link to comment
Share on other sites

Who me? B)

:D

In my own defence, I know bugger all about hardware (I mean, seriously, I just don't do hardware at all) so it's only by the good grace of the TechnoGods that I didn't just try to wire the thing directly to my printer or something :D

Now there's an idea.....

Link to comment
Share on other sites

What did you do? Try to build it from a normal cable rather than a usb-serial one?

Maybe you can save me some grief.

What do you mean by a usb-serial cable? I saw in the example where you were using a camera cable with a phone plug on the (unused) end, but don't the wires connect directly to the usb type A plug on the other end?

What I've done so far (following the thread in the forum) I took a standard USB cable with a type A plug on one end and a mini-B on the other, and clipped off the mini-B connector. What I now have is the red wire connected to the "A" plug pin 1 (Vcc) the white to pin 2 (Data -) green to pin 3 (Data+) and black to pin 4 (Gnd). I checked that with a meter and with the usb standard.

I was getting ready to connect the Data+ to Pin 2 on the Fon (Rx, yellow in the example) and Data- to pin 3 (Tx, red in the example) and Gnd to pin 5. If that doesn't work I was planning to reverse the Data+ and Data-

Next on the XP end of things, is there anything I need to do to set up the connection?

Walt

Link to comment
Share on other sites

STOP!!!!!

You can't use a normal USB cable, you need a special cable, hence the Kyocera one.

The cable you are building isn't a usb cable, it is a usb to serial cable which needs the voltages modifying. The special cable does all this for you.

I'll update my site so that this is clearer.

Link to comment
Share on other sites

Nice one :)

That's where I went wrong, it wasn't until I found about my 4th/5th guide to making these types of cables that I realised why nothing seemed to be working ;)

I've now ordered one of the Nokia CA-42 cables which are also supposed to work, hopefully I'll have more luck with that :D

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...