Jump to content

Problems with IP address


Recommended Posts

I'm starting with a working Fon, with Jasager 2.1 installed, and following the wiki at http://wiki.hak5.org/wiki/Internet_Connect...mit_Der_Jasager.

After changing the IP address of the Fon lan connection to, DHCP, bridged, and with the Ethernet port on the PC set to, I cannot connect. I've tried setting the PC port to DHCP to no avail. I've waited up to 10 minutes after a cold boot of the Fon to give it plenty of time to start up.

The settings seem reasonable - as I read the screen the Fon will try to get an IP address from the Ethernet connection, and if it can't will default to the one we've provided - After that it should be able to connect directly with a PC with an address in the subnet. Correct?

Since at this point I cannot communicate with the Fon at all, I have gone back to re-flashing the ROM (twice).

Can anyone help me with this connection problem?



Link to comment
Share on other sites

I don't think you are right on the IP address stuff but I don't have a device to hand to check. I don't think you can't set an IP and dhcp, you have to chose one or the other. Why are you trying to set dhcp and a static ip? Why not just go for the static one.

Where is your dhcp server running? Look at its logs and see what ip address it issues, or you can run a packet sniffer and watch the traffic for the dhcp request/answer, the answer will contain the ip address issued.

Usually if an interface can't get an IP address it will default to one in the subnet. It may take a while but you could try ping sweeping that range to see if you can find it there.

Link to comment
Share on other sites

I don't think you are right on the IP address stuff but I don't have a device to hand to check. I don't think you can't set an IP and dhcp, you have to chose one or the other. Why are you trying to set dhcp and a static ip? Why not just go for the static one.

I agree. My recollection from setting up DD-WRT on my Linksys AP - a long time ago - was just that. For some reason, this X-Wrt GUI only opens up the IP Address box when you choose "DHCP" from the combo box (see the wiki, http://wiki.hak5.org/wiki/Internet_Connect...mit_Der_Jasager about 1/2 way down) The text next to the IP address box states that this address is used as the default if a DHCP server is not available - which is the case in my setup.

Just to be sure i have the right idea,

Der Jasager is plugged in by the Ethernet cable to the Ethernet port on my laptop. This is in the example. The other interface on the laptop, a wireless interface is authenticated to my AP and then connected to the Internet. This interface is set up for ICS. When "Victim" comes along looking for "MY-AP", Der Jasager says "OK, that's me!". Now "Victim" is connected to the Internet through my laptop as a MITM.

Do I have it right?


Link to comment
Share on other sites

The second bit is right, for the first bit, if you can't find the IP address and have to reflash then just set a static IP so you can be sure what IP the Fon is on.

You didn't say what DHCP server you were using.

Link to comment
Share on other sites

I'm making progress, but still a bit confused.

I have the Ethernet port on my PC set to a fixed IP address of and Der Jasager to, and they connect fine. It turns out that you need to switch to DHCP to get the IP address box to shoe, then back to Fixed.

I have the WIFI connection on my PC set to Internet Sharing, and it is connected to my office AP. however, unlike the Microsoft documentation, it has a "real" IP address - that was assigned by the DHCP server on the network. the Microsoft documentations says that the adapter doing the sharing will be set to

Doesn't Der Jasager do DHCP for the wireless connections to its "victim"? When I connect to him by looking for an AP named "linksys" I get assigned an IP address of so why do I need to have a DHCPD running on the PC? I've read the other thread on this subject and am becoming more confused by the minute :-(

Sorry to be so stupid about this.


Edit: 2 hours later.

I now have Der Jasager and the PC talking as (PC) and (Fon) - both fixed IP addresses, and a Verizon wireless modem set up as the shared connection. I changed the IP of the Ethernet to correspond with Microsoft's convention. Once again, I can connect to Der Jasager over WIFI and get assigned but the connection sharing does not seem to be working.

So I fired up Wireshark to see if I could learn anything. I can ping (the Ethernet port on the PC)from the client, but no further. If I try to ping back (from the PC) I generate a bunch of ARP requests:

Who has Tell

I'll probably quit here for today. I'm grateful for any ideas, and I'll check back in the morning


Link to comment
Share on other sites

If you're trying to get your fon to be acessible via lan, with your main router as the DHCP server, try this:

1. SSH into the fon or use a serial cable to open up a terminal.

2. Edit /etc/config/network

vi /etc/config/network

And make your fine look like this. (hint: press "a" to enter edit mode, "Esc" will exit edit mode, ":wq" will write the file and quit)

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr
        option netmask

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    dhcp
#       option ipaddr
#       option netmask

3. Restart networking

/etc/init.d/network restart

4. Run udhcpc to detect network settings.


5. You're Done! Test to see if it works by installing an ipkg over the internet, or you can also test it by running:

ipkg update

and make sure that there are no error messages.

Make sure to let us know if it works or not. :)

Link to comment
Share on other sites

I assume then that I would plug the Fon Ethernet wire directly into the network, not into the PC?

In any event, aren't you doing the same thing as the GUI would do setting up for DHCP and no specified IP address? Not that I have anything against vi - we're old friends from using the Nokia and Zaurus!

I've kind of shut down for the night now, will try more things in the morning.

Thanks :-)


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...