Jump to content

Vista install of U3 packages


Recommended Posts

does the installer for the titanium work for non titanium drives?

C++ I might be able to help you with this in a few days, school and what not. If you will send me a pm just to remind me & with your email, I will do a quick modified installer and send it to your email.

im still not quite clear on if you had sucessfully hex edited the executable? and if so could you maybe do a walk through. I was trying to go off your previous posts and couldn't find the location in hex-ed where the sandisk.com website is linked... i did however find that in olly debugger but im not exactly sure how to change it to what i want it to be....

Link to comment
Share on other sites

  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Ok i went back threw my previous direction and see no problem with them. This isnt an issue for people trying to install packages to their drives on vista, there is already a program for that, this is more of a mass distribution kind of thing. This is what a company or business would want to use if they had a special u3 package that they wanted downloaded and put on drives. I mean its not that hard to extract the .exe, open the other exe in "HEX-ED" and go to line 111810.. i mean honestly. Editing the url is a little different but if you pm me with the url you want to use then i will do my best to give you the string to type in, but its really not hard.

Link to comment
Share on other sites

[Don't want to hijack the thread, but this is about the localhost method, as it seems like there still some confusion about it. And it's how I did it using Vista... since some of the old versions of lpinstaller don't work for Vista (I'm dealing with version 1.6, can anyone confirm they have switchblade working with this version?)]

I had tried this a long time ago, and I recently tried it again it does not work for me!

I have an apache web server running on my machine... If I modify my hosts file and and point u3.sandisk.com to

When I try to run lpinstaller it fails immediately! It says "Download of u3 launchpad failed!"

I did get the same message, so I had to tweak a few things myself.

I guess one easy way to go about checking the web server:

First, check the Apache logs, like the access/error logs, to see if a file was requested.

If there was a file requested, you can see what a particular file was requested, and where it should be located. You can make the necessary nested folders to hold your file in the htdocs folder.

On the other hand, it could be that you haven't yet told the server who it is supposed to be. To do this, add the code to the httpd.conf file in the Apache conf folder:

ServerName www.u3.com:80

=> [in this case you can also add another line to the host file]

or if you downloaded from sandisk:

ServerName u3.sandisk.com:80

I'd guess it's one of these two things, i.e. the folder structure wasn't correct or the server file (httpd.conf) wasn't configured. If not, then we can try to figure out what else is needed.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.

  • Create New...