Jump to content

Karma problem


Recommended Posts

Ive setup my Fon per the very nice walk though (thanks Darren). Ive configured the lan interface on the fon to use my wifi card on my laptop as the default gateway, enabled ICS on a second wifi card and connect it to the real wifi connection that has internet. So this allows clients connected to the fon to surf. Problem im having is I have Karma turned on but it doesnt seem to be working. The only connection being listed in the available wifi connections is the openwrt (default wifi connection on fon). Have i missed an important step perhaps?

Im attaching a screenshot showing karma is enabled and the list of available networks. Ignore the netgearwtc as thats an actual access point for my company. But if karma was working i should see the networks for my house and a few other places i frequent with my laptop.

Any help would be greatly appreciated!

post-700-1223568980_thumb.jpg

Link to comment
Share on other sites

It looks like it is working perfectly to me. Jasager doesn't have an SSID so the fact you connected to OpenWrt means that you connected to an AP that doesn't really exist.

Also, once you are connected then you stop sending probe requests so the others won't show up. Try removing the OpenWrt AP from the list and put an alternative unsecured, auto-connect SSID in and it should connect to that.

Link to comment
Share on other sites

It looks like it is working perfectly to me. Jasager doesn't have an SSID so the fact you connected to OpenWrt means that you connected to an AP that doesn't really exist.

Also, once you are connected then you stop sending probe requests so the others won't show up. Try removing the OpenWrt AP from the list and put an alternative unsecured, auto-connect SSID in and it should connect to that.

hmm your right it is working. Created a new connection called somerandomssid but it wouldnt connect so i looked deeper into the settings and it seems to only work if the check box labeled "Connect even if the network is not broadcasting" is checked.

PS- Thanks for all your time spent on this project, its very interesting!

Link to comment
Share on other sites

hmm your right it is working. Created a new connection called somerandomssid but it wouldnt connect so i looked deeper into the settings and it seems to only work if the check box labeled "Connect even if the network is not broadcasting" is checked.

PS- Thanks for all your time spent on this project, its very interesting!

No problem.

If you are using it at work and your company would like to make a donation, please feel free to get in touch. I'm happy to offer corporate support deals.

Link to comment
Share on other sites

No problem.

If you are using it at work and your company would like to make a donation, please feel free to get in touch. I'm happy to offer corporate support deals.

Not useing it for work just working on it on work time. aka slow day.

Link to comment
Share on other sites

Ive setup my Fon per the very nice walk though (thanks Darren). Ive configured the lan interface on the fon to use my wifi card on my laptop as the default gateway, enabled ICS on a second wifi card and connect it to the real wifi connection that has internet. So this allows clients connected to the fon to surf. Problem im having is I have Karma turned on but it doesnt seem to be working. The only connection being listed in the available wifi connections is the openwrt (default wifi connection on fon). Have i missed an important step perhaps?

Im attaching a screenshot showing karma is enabled and the list of available networks. Ignore the netgearwtc as thats an actual access point for my company. But if karma was working i should see the networks for my house and a few other places i frequent with my laptop.

Any help would be greatly appreciated!

post-700-1223568980_thumb.jpg

Can you further document how you setup ICS? I'm thinking of doing the same thing on my laptop, but instead of a second wifi card I'd like to use my verizon wireless card.

Link to comment
Share on other sites

Can you further document how you setup ICS? I'm thinking of doing the same thing on my laptop, but instead of a second wifi card I'd like to use my verizon wireless card.

Go into the properties of your internet connection select the share tab.

networkadapterproperties.jpg

When you enable sharing though it changes the ip on your other adapter to a static ip. you will need to go into your wifi properties and set them back to dhcp.

wifiproperties.jpg

then goto your fons webif interface to configure the gateway to the IP of your wifi card.

http://192.168.1.1/cgi-bin/webif/network.sh

For some reason i had to change the drop down where it says static to dhcp then back to static in order for all the fields to display. But once they show up just set the gateway as your wifi cards ip and a dns server. (could use opendns to screw with them even more with this setting i believe)

webifnetworkconfig.jpg

Ive never done a writeup on how ive done something before so im sure this is crappy and hard to follow but if there are questions ill try and answer them as best i can.

Link to comment
Share on other sites

This is how I tried to set up my lab. Alfa NIC was set up with ICS.

jasager_lab.png

Result = Once I powered on Der Jasager, the Alfa card was connected to the fake WRT54G. Der Jasager is taking over the job of my physical WRT54G.

I'll continue to experiment. Any help would be appreciated.

- Edit -

Ahzo! I think I have to add WRT54G to Der Jasager's whitelist. My network configuration looks jacked up too. I'll try again tomorrow evening. The sandman is calling.

Link to comment
Share on other sites

This is how I tried to set up my lab. Alfa NIC was set up with ICS.

jasager_lab.png

Result = Once I powered on Der Jasager, the Alfa card was connected to the fake WRT54G. Der Jasager is taking over the job of my physical WRT54G.

I'll continue to experiment. Any help would be appreciated.

- Edit -

Ahzo! I think I have to add WRT54G to Der Jasager's whitelist. My network configuration looks jacked up too. I'll try again tomorrow evening. The sandman is calling.

I had the same problem at first but found that if i connect to the internet first then power on the fon it would work.

Link to comment
Share on other sites

@Iyeman: Thanks. Will try tomorrow and report back.

- Edit - 0234:

Each time I enable ICS, whether on one of my laptop's wireless NICs, or my wired connection, I can no longer access the Inet on the laptop. Also can not connect to the Inet via: Mark>Jasager>ICS'ed Laptop>Inet connection.

I'm seriously going to bed lol.

Link to comment
Share on other sites

@Iyeman: Thanks. Will try tomorrow and report back.

- Edit - 0234:

Each time I enable ICS, whether on one of my laptop's wireless NICs, or my wired connection, I can no longer access the Inet on the laptop. Also can not connect to the Inet via: Mark>Jasager>ICS'ed Laptop>Inet connection.

I'm seriously going to bed lol.

The only difference i see atm in our configs is your gigabyte GN-WS50G connections settings. Is it set for dhcp or statically configed?

Mine is set for dhcp and gets the following for the settings

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : lan

Description . . . . . . . . . . . : Dell Wireless 1390 WLAN Mini-Card

Physical Address. . . . . . . . . : 00-1A-92-9C-B7-D8

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IPv4 Address. . . . . . . . . . . : 192.168.1.247(Preferred)

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Lease Obtained. . . . . . . . . . : Friday, October 10, 2008 8:21:38 AM

Lease Expires . . . . . . . . . . : Friday, October 10, 2008 10:08:52 PM

Default Gateway . . . . . . . . . : 192.168.1.1

DHCP Server . . . . . . . . . . . : 192.168.1.1

DNS Servers . . . . . . . . . . . : 192.168.1.1

Link to comment
Share on other sites

That's a no/go. I'm back to the "both WAPs associate to Der Jasager" issue.

- Der Jasager is powered down

- I set up the Alfa card with DHCP, associated to the WRT54G

- I set up the GN-WS50G with DHCP and didn't let it associate to a WAP

- Powered up Der Jasager

- Once Der Jasager was powered up, I associated the GN-WS50G to it, and in the same instance, the Alfa card associated itself as well.

Link to comment
Share on other sites

This is how I tried to set up my lab. Alfa NIC was set up with ICS.

Result = Once I powered on Der Jasager, the Alfa card was connected to the fake WRT54G. Der Jasager is taking over the job of my physical WRT54G.

I'll continue to experiment. Any help would be appreciated.

- Edit -

Ahzo! I think I have to add WRT54G to Der Jasager's whitelist. My network configuration looks jacked up too. I'll try again tomorrow evening. The sandman is calling.

Not quite, the white list is the list of things that it will only reply to, you want to use black list mode and add the ESSID then. That means that the ssid of your WRT will be ignored.

Link to comment
Share on other sites

digininja: thank you for the clarification. I reset the SSID list. set Der Jasager to Blacklist mode, added the WRT's SSID to the list, and powered down der Jasager.

- Associated the Alfa NIC to the WRT54G

- Powered on Der Jasager

- Associated the GN-WS50G to OpenWRT (Der Jasager)

- Associated Mark (The laptop I'm trying to get to access the Inet through Der Jasager>ICS'ed laptop>Inet connection)

- No Inet connection.

Still not able to pass traffic through an ICS'ed connection, or access the Internet while this configuration is in place.

When I power down Der Jasager, I can then connec to the Internet

Link to comment
Share on other sites

Iyeman: I tried to perform a tracert to google.com from the client connected to Der Jasager. It just sits there (for a lack of a better term).

I can ping from the client>through Der Jasager>to the IP of the GN-WS50G NIC. That's as far as I can go.

digininja: I think you're right. I set up DNS in the webif interface on the fon. It's got that same wonky issue mentioned in an another thread. Once I change and save the network settings (IP, gateway, add DNS servers) in webif, I have to switch between DHCP and Static IP in order to view the changes.

When I do an ipconfig on the ICS'ed laptop, the settings for the GN-WS50G NIC are using the the fon's IP for its gateway and DNS servers.

I'm connecting out in two directions. Neither side is "flowing"

Link to comment
Share on other sites

Iyeman: I tried to perform a tracert to google.com from the client connected to Der Jasager. It just sits there (for a lack of a better term).

I can ping from the client>through Der Jasager>to the IP of the GN-WS50G NIC. That's as far as I can go.

digininja: I think you're right. I set up DNS in the webif interface on the fon. It's got that same wonky issue mentioned in an another thread. Once I change and save the network settings (IP, gateway, add DNS servers) in webif, I have to switch between DHCP and Static IP in order to view the changes.

When I do an ipconfig on the ICS'ed laptop, the settings for the GN-WS50G NIC are using the the fon's IP for its gateway and DNS servers.

I'm connecting out in two directions. Neither side is "flowing"

after setting GN-WS50G NIC to dhcp did you go back into the webif and change the gateway of the fon to the ip of the GN-WS50G NIC?

Link to comment
Share on other sites

Got it!

I shut everything down and started from scratch. After googling/reading a bit, I tried again.

When you create an ICS connection, you'll be using two NICs. The one I'm using to connect to my WRT54G (and thusly the Internet) is "Alfa".

When I set up Internet Connection Sharing, the IP address on the other NIC in my laptop (Atheros) was changed to a different subnet, without a a gateway (because it is a gateway now). Leave this setting alone.

Once I had that all squared away, I fired up Der Jasager, associated to it with the Atheros NIC, opened up the webif interface and set the network configuration to DHCP. After this I used angry IP scanner to find Der Jasager's IP, so I could verify the settings.

jasager_lab2.png

Voila! All is good.

Now then, this was all done, without Karma enabled on Der Jasager. That's the next dilemma. It seems as if every time I fire up Karma, in any given order, both NICs on my laptop want to associate to it. That's outta my hands. Any thoughts?

Be well.

Link to comment
Share on other sites

Now then, this was all done, without Karma enabled on Der Jasager. That's the next dilemma. It seems as if every time I fire up Karma, in any given order, both NICs on my laptop want to associate to it. That's outta my hands. Any thoughts?

Be well.

Make sure you are in blacklist mode, add the ssid of the legit AP (openwrt) so that Karma ignores it then start karma. Your alfa may then try to associate with it but it will be rejected. The only problem I can see is the laptop trying so hard to associate with it that it doesn't get chance to associate with the real ap. Have you tried doing a wired link between the laptop and the openwrt?

BTW, what are you using for the diagrams? I like them.

Link to comment
Share on other sites

digininja: During the course of working this out, I did have a wired connection between the laptop and the WRT54G. Trial and error. :rolleyes:

I'll definitely be working more on this later today, after I catch some shuteye. I wanna thank you again for reiterating/clarifying the White/Blacklist situation I'm having. It'll lock into my brain, once I do it a few times.

I'm using Visio to create the diagrams. I tried to locate a WRT54G shape or something that would allow me to create shapes, but I didn't spend too much time on it.

Iyeman: the LCARS setup on your web site is nawiiice. I like that very much.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...