Jump to content

MDK4


chris2008
 Share

Go to solution Solved by chris2008,

Recommended Posts

Hi guys,

I'm slowly working my way through and solving problems as I get used to the Pineapple 7. I have tried to use the MDK4 using the Deauthentication and Disassociation (just on my own router) following the video made by Sgt Foose. However, when I click start I get the following errors in my Output window:

image.thumb.png.818e8475fae9eb2798a957ea66b77792.png

As you can see I am using the 2.0.0 Beta Version

 

Edited by chris2008
Link to comment
Share on other sites

27 minutes ago, dark_pyrro said:

There's a library package missing (not sure what the second screenshot should show though)

Yes, I realised that but my hope was someone on here maybe knew which one.

The second screen shot was showing there was no mdk4 folder.

Link to comment
Share on other sites

My next question. Sorry if I am annoying people with my noob questions (in terms of the Pineapple) but I tried to install libcap.so.0.8 but got:

root@mk7:/pineapple# opkg install libcap.so.0.8
Unknown package 'libcap.so.0.8'.
Collected errors:
 * opkg_install_cmd: Cannot install package libcap.so.0.8.

Am I doing it wrong?

Chris
 

Link to comment
Share on other sites

  • Solution
3 minutes ago, dark_pyrro said:

libpcap not libcap

Yes, that was a typo, but doesn't make any difference.

Anyway sorted it out. For anyone struggling with the same problem in the future I solved it by the following:

ln -sv libpcap.so.1 /usr/lib/libpcap.so.0.8

Link to comment
Share on other sites

I guess mdk needs to be recompiled for the new OpenWrt version so that the dependencies will be correct (it seems as if the 19.07 repo also has moved up to a newer version of libpcap since this wasn't a problem before). Symlinking will just be a temporary workaround as there's no guarantee that it will play ball (a review has to be made between the two library versions to see if a symlink is a more long term solution or not). The mdk version that is installed is also a version that is reported to have some issues (in other threads here on the forums). The solution to that seems to be to use the mdk4 compiled by adde88 on GitHub. That still is depending on the older libpcap though so it doesn't solve that specific dependency.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

On firmware 1.1.1 I also get an error when trying to install MDK4 (see red below). The manual way described above does work for now but not as a module of course.

exit status 1
PUT http://172.16.42.1:1471/api/modules/install 500 (Internal Server Error)
 
Link to comment
Share on other sites

16 minutes ago, dark_pyrro said:

Do you get that error when installing the module itself or the dependencies?

Just the module. I did manage to get Cabinet, Evil portal, MTR, TCPdump, HTTPeek and Nmap to install without issues. Locate, MDK4, MACInfo have the same error.

Link to comment
Share on other sites

This is what I posted on Discord. Might shed some light on the issue.

 

The "exit status 1" issue that was mentioned here recently is probably because the installer in the modules section of the Pineapple UI is referencing files that doesn't exist. At least myself and one more here have experienced this and also at least one other user on the forums. It does not seem beta related since users have had issues running 1.1.1. I've never had any problems with this before so I'm sure it is something related to a change of some kind. When trying to install MDK4, Locate and MACInfo I get "exit status 1". Tried different browsers, incognito windows, different machines, but the result is the same. So, to reproduce it, you go into the modules section in the Pineapple web UI, "Modules" tab, click "Get Available Modules", click "Install" on the line representing the MDK4 module, click "Install" once again in the popup. Animation starts spinning where the Install button normally is located. The install procedure then stops after a short while and throws back the red text "exit status 1". Now, when looking under the hood, it seems that the expected tar.gz of the module can't be found by the installer. In an ssh session, it's possible to see that the installer downloads to /tmp every time the installer is initiated and more specifically a file named "downloadModule.tar.gz" is created.

The contents of this file isn't what should be expected of a true tar.gz file since it contains a text based error message.
 

<?xml version='1.0' encoding='UTF-8'?><Error><Code>NoSuchKey</Code><Message>The specified key does not exist.</Message><Details>No such object: hak5-dl.appspot.com/wifipineapplemk7/modules/mdk4/mdk4-1.0.tar.gz</Details></Error>

Reading the error message above, it's obvious that the installer tries to download the 1.0 version of the module, but can't find it. The file that is available for download is currently versioned 1.3 as far as I know.

So, the theory is that a tar.gz is made available to the installer/system after download, but it's "currupt" since it contains an error message instead of the content of a correct tar.gz file and can't be used by the installer. I guess that's what happening behind the scenes and issues the error that can be seen in the web UI.

It's the same for the Locate module (an error message in the created/downloaded tar.gz file similar to the one above). MACInfo is a bit different though since that tar.gz is totally empty (0 size). Something's wrong there as well, but no "easy clues" of what might be wrong.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...