Jump to content

Keyboard not working through Key Croc


40trieslater
 Share

Recommended Posts

Just received my 2020 elite field kit the other day and have been getting around to testing everything out. Thank to the team at Hak5 for that. 

I have been experiencing some issues with the Key Croc and I'm really unsure at this point what the problem is.
The first thing I did was upgrade to the latest firmware, so I don't know if it's a firmware issue. 
I have got the croc online and connected to my c2c, all is great. Except, when I plug a keyboard into the croc, I can't actually use the keyboard, nor does it record any of the keystrokes. 

At first I thought maybe it could be my keyboard (Corsair K95 Platinum) so I tried one of those old Microsoft USB Keyboards I had laying around and that didn't work either. 
Finally I used another computer to test both keyboards, which again did not work. 

At this point I find it hard to believe that it is a fault with the croc, the OS loads, It connects to wifi, I can SSH into it, put it into arming mode, it all works....It just doesn't route the keyboard through the device very well. 

DUCKY_LANG is set to "US" also.

Any Ideas? 

Link to comment
Share on other sites

Thanks Spywll, 

It's really strange, I followed that process twice and both times it was flashing the firmware but it didn't actually flash back to V1. 
So I have no idea what's going on really. 

It still doesn't log any keyboard strokes and the keyboard still doesn't work when plugged between the croc and the PC. 
And both the online and the keycroc loot folder contain the same keystrokes "[CONTROL][CTRL-SHIFT][CONTROL][CTRL-SHIFT][CONTROL][CTRL-SHIFT][CONTROL]"

This is so strange!

Link to comment
Share on other sites

Okay, so...

When I plug the croc in and set it into arming mode, the version.txt file within it displays v1.3 as the firmware. 
But if I SSH into it, there is a single version.txt file in the root folder which says v1.1. 

Also within the root folder is a udisk directory which has all the contents of the flash drive partition. So therefore I think maybe it did flash back to v1.1 but the old version file is still in the udisk directory. 

Either way, it still doesn't work. 

Link to comment
Share on other sites

Okay, I have a breakthrough. 
I tested this on my Laptop which doesn't have the latest Windows 10 Update on it. 

Windows 10 Home 1909
It works!

I'll update windows on that laptop to see if it might be the cause of the problem 
The windows version which I have previously tested it on is Windows 10 Pro 2004
Which doesn't work. 

Also the /tmp logs were all blank, I feel like these other PC's I've tested it on have somehow blocked it. 

 

Link to comment
Share on other sites

@40trieslater here are my thoughts based on your posts:

After a factory reset, the system is restored from a backup partition however the udisk may be untouched – so this probably explains the discrepancy with your udisk/version.txt

The control keys you are seeing indicates that your keyboard is not a generic HID keyboard, but rather a "fancy" composite device containing multiple HID devices (usually for multimedia controls, RGB LED controls, etc). We have also seen this behavior with bluetooth keyboards that happen to have USB functionality (for charging) like the Apple Magic keyboard and Microsoft Surface keyboard.

It may have nothing to do with your Windows 10 Home 1909 version but rather that you tried it on a different computer, and in doing so the race condition was in your favor. Meaning, when the "fancy" keyboard enumerated on the Key Croc it presented multiple HID interfaces (part of what's called a USB Composite device) and each of those interfaces were mapped to HID channels. The Key Croc from v1.0 - 1.3 is expecting a single HID channel, with the regular keyboard as the first device. The additional HID channels are currently ignored. When the multimedia keys enumerate first, you get these odd results. When the regular keyboard keys enumerate first, you get keystrokes as expected.

My guess is that in this case with the Windows 10 Home box, the regular keyboard keys enumerated first and everything worked. In the case of these "fancy" composite keyboards, it's luck of the draw as far as that race condition goes. It's something we're working on and hope to have a firmware update to address soon. In the meantime, I recommend trying with a standard keyboard while we nail down this bug.

I hope that sheds some light on your issue. I'm aware that it's not a perfect answer, but it's the honest truth for the moment until we solve for composite devices. Anyone reading this in the future please be aware that this is an issue specific to firmware 1.0 through 1.3 – I know how these threads tend to linger on (also I hope the world is in a better place future hackers).

Link to comment
Share on other sites

Thanks Darren, 

I have now tried using the Microsoft Keyboard on my Desktop and it seems to work now. 
I'm still not quite sure why this is the case, but it could have something to do with testing the Corsair K95 keyboard first which may have caused some corruption on the croc, therefore it won't work on any device until I do a factory reset and use the Microsoft keyboard first. 

Either way, I don't think this in an issue with Windows 10 in this case, but more so the Keyboard/Croc comparability as you've said. 
But I do agree that there is a bug as stated above. 

For now though, I know that the croc isn't defective in anyway, so I'll be happy to wait for a new firmware update. 

Thanks for the help Darren/Spywll.

Link to comment
Share on other sites

  • 3 months later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...