Jump to content

Autorun.inf Support...


twsSentinel
 Share

Recommended Posts

Hello all,

I've written an excellent payload for USB. It's been modded quite a lot from the others on here and I think you will all like it. Before I post the current version, I'm having some problems with the Autorun. I can't seem to get it to run my script or anything. I'm guessing its something in the OS, but then I tried it on a WinXP machine and still no luck. Im doing most of the testing as of now on win2003 server.

Any clue why I can't get it to automatically run?

Link to comment
Share on other sites

If you are talking about a regular usb stick it will not automatically run with only a autorun file (not on a normal installation anyway), those only works on CDs which is why the U3 ones fakes being a CD.

Also, learn how to ask a question. It really is a good skill to have. Asking how to fix something without showing what needs fixing or giving any details about what goes wrong only lets the psychics like me answer the question. And the number you are thinking of is 69 dude.

Link to comment
Share on other sites

thanks for the reply's ... I've tried every-which-way to write the autorun.inf and still no luck. I have an Ativa U3, but with the SanDisk LaunchU3.exe installed.

Anyway, once U3's developer site is back working, I'll register and package the payload as a software app.

Thanks again guys.

Link to comment
Share on other sites

To all U3 developers or c++ programmers as well:

I have written a small program which executes a vbscript file without the use of a console windows displayed:

I am able to successfully build and installed my u3p. application after using U3 Package Prototyper as well as PackageFactory; however for some reason U3 doesn't like to run my exe file successfully.

Heres the code:

In the Project -> Settings -> Link -> Project Options

I set "/subsystem:windows" instead of "/subsystem:console". This way i can completely get rid of the console window.

#include <shlobj.h>





int APIENTRY WinMain(HINSTANCE hInstance,

                     HINSTANCE hPrevInstance,

                     LPSTR     lpCmdLine,

                     int       nCmdShow)

{



    ShellExecute(NULL,"open",".QuietRiot.vbs",NULL,NULL,0);



    return 0;

}

if I manually double-click the exe, it works flawlessly, why won't it work with U3?

any ideas?

Link to comment
Share on other sites

Well since it is running the vbs file with a relative path you need to make sure you are in the right directory. When you double click it the current directory is set to where the exe is but when running from an autorun or other script it is most likely set to where the script is.

Link to comment
Share on other sites

without the scriptserver needed to be running

really? wow, I'd been wondering how to go about doing that! Is your loader in the amish package? I don't remember if that was u3 or not, would you mind pointing me towards your loader? I would greatly appreciate it, thanks!

edit!: sorry for the trouble I have located it myself here http://www.hak5.org/packages/files/nakaoris.loader.zip

one question though, wouldn't putting a copy of nircmd on the cdrom partition and running the search batch file with it make this completely silent?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...